3 Replies Latest reply on Feb 14, 2003 11:22 AM by Kevin McIntyre

    Jetspeed deployement - Urgent help needed

    Christophe Cocquet Newbie

      Hi all,

      I'm trying to deploy Jetspeed 1.4b1 under JBoss 3.0.x (I tried 3.0.0, 3.0.2, and 3.0.3).

      I deploy Jetspeed by unpacking jetspeed.war in the deploy directory (no problem with that). I have to deploy that way because jetspeed uses the getRealPath() method which returns null if the war is not unpacked.

      Here is the server log with JBoss 3.0.0 with Tomcat 4.0.3 (quite similar with other versions of JBoss) :

      INFO [org.jboss.deployment.MainDeployer] Starting deployment of package: file:/D:/Java/jboss-3.0.0_tomcat-4.0.3/server/default/deploy/jetspeed.war/
      ...
      INFO [org.jboss.web.localhost.Engine] StandardManager[/jetspeed]: Seeding random number generator class java.security.SecureRandom
      INFO [org.jboss.web.localhost.Engine] StandardManager[/jetspeed]: Seeding of random number generator has been completed
      INFO [org.jboss.web.localhost.Engine] ContextConfig[/jetspeed]: Added certificates -> request attribute Valve
      DEBUG [org.jboss.web.catalina.EmbeddedCatalinaServiceSX] Context.lifecycleEvent, event=org.apache.catalina.LifecycleEvent[source=StandardEngine[MainEngine].StandardHost[localhost].StandardContext[/jetspeed]]
      INFO [org.jboss.web.catalina.EmbeddedCatalinaServiceSX] Using Java2 parent classloader delegation: true
      INFO [org.jboss.web.localhost.Engine] StandardWrapper[/jetspeed:default]: Loading container servlet default
      INFO [org.jboss.web.localhost.Engine] default: init

      ... and the server hangs !

      Any idea of what might be wrong ?
      I've seen in the forum that some already installed succesfully jetspeed with JBoss, how ?

      Thx in advance.

        • 1. Re: Jetspeed deployement - Urgent help needed
          Magnus Berg Newbie

          I have the same problem. Tried JBoss3.2.0beta as well.

          ...

          Now I actually got it started. I found a post on the jetspeed-user mailing list:

          http://www.mail-archive.com/jetspeed-user@jakarta.apache.org/msg05702.html//www.mail-archive.com/jetspeed-user@jakarta.apache.org/msg05702.html

          With the manifest-file, it starts, but:

          1. If I access the http://localhost:8080/jetspeed URL, it redirects infinitely. Mozilla says "Redirection limit for this URL exceeded.", IE blindly follows each redirection. The .../jetspeed/portal URL works.

          2. There's no icons, I guess the paths all get mangled or should be changed when running JBoss?

          3. Jetspeed hi-jacks the log!? Everything that should be printed to the JBoss console ends up in .../WEB-INF/log/jetspeed.log.

          4. The customize page doesn't look the way it should. Some links from it also redirects infinitely. Probably the same problem as 1 and 2.

          Somebody seen this? Solutions?

          Thanx in advance.

          • 2. Re: Jetspeed deployement - Urgent help needed
            sue leung Newbie

            with the help of Ramiro, I made jetspeed working under jboss-3.0.3_tomcat-4.1.12.

            For the logging, I don't remember how i made it
            working... and I did 2 things and don't know which
            one make my logging working properly... firstly, I
            sync. log4j for both jetspeed and jboss.. as they are
            using different versions. Then i think at the same
            time i played around with the TurbineResources.properties
            as well...
            My suggestion: try to sync. log4j first and see if this
            fix the problem.. if this doesn't help, i can send you my
            TurbineResources.properties file.

            • 3. Re: Jetspeed deployement - Urgent help needed
              Kevin McIntyre Newbie

              I've had no real problems getting jetspeed to work under jboss.

              I created a jetspeed.war directory in deploy.

              Then I remove castor.jar out of default/lib.

              The ldap authentication was a pain. But eventually I got that to work as well. The main problem was that the jetspeed.ldif file didn't work with ldapadd. I broke it into two files. The entries before the the users and then the entries begin with the users all the way to the end.

              I also modified TurbineResources.properties to log directory to the default/log by utilizing the ${jboss.server.home.dir} property.

              I've also encountered the hijacking of my jboss console which is just annoying but it doesn't prevent jetspeed from working properly.