3 Replies Latest reply on Oct 8, 2002 3:49 PM by Kenny Flegal

    Console Stream looping error with Web Work on Jboss 3.0.3

    Kenny Flegal Newbie

      When installing Open Symphony's Web Work I get the following error:"Invalid Console Appender Config detected Console Stream is looping" when starting jboss. After doing some searching I have found that the problem is with the what that log4j is being used by webwork though I am not really finding information on how to fix the problem. I have tried uncommenting the section of the log4j.xml as well as commenting out all the information but the section and removing the file all together in hopes that the main log4j.xml for jboss was used but have had no luck. Does anyone know how to fix this problem? Any help that you could give would be greatly appreciated.

        • 1. Re: Console Stream looping error with Web Work on Jboss 3.0.
          Adrian Brock Master

          Remove the log4j configuration from webwork.properties

          # override default log4j config
          # you can use .properties or .xml
          # if you want to use default set property to null by an empty =
          #webwork.log4j.configfile=log4j.properties
          webwork.log4j.configfile=

          Otherwise it will try to reconfigure log4j which
          leads to an infinite loop as log4j tries to print to
          System.out which is trapped by JBoss's config
          and re-routed to log4j.

          Use server/default/conf/log4j.xml to configure
          webwork's logging as required.

          Regards,
          Adrian

          • 2. Re: Console Stream looping error with Web Work on Jboss 3.0.
            Kenny Flegal Newbie

            I have changed the property files of both webwork.jar and webwork-examples.jar and have the webwork.war in the deploy directory. The war file itself doesn't refer to log4j.xml. I am still however getting the error, I don't know if it will help but have included the information from jboss:

            15:55:30,536 INFO [MainDeployer] Starting deployment of package: file:/usr/local/jboss/server/default/deploy/webwork.war
            15:55:34,152 INFO [jbossweb] Registered jboss.web:Jetty=0,JBossWebApplicationContext=2,context=/webwork
            15:55:34,751 INFO [jbossweb] Extract jar:file:/usr/local/jboss/server/default/tmp/deploy/server/default/deploy/webwork.war/59.webwork.war!/ to /tmp/Jetty__8080___webwork/webapp
            15:55:36,545 INFO [jbossweb] Started WebApplicationContext[/webwork,jar:file:/usr/local/jboss/server/default/tmp/deploy/server/default/deploy/webwork.war/59.webwork.war!/]
            ERROR: invalid console appender config detected, console stream is looping

            As a note I did not install log4j as I assumed (wrongly?) that I wouldn't need that package as jboss already seemingly has it. Is this a problem? Any other ideas of what could be causing this problem or what I am missing?

            Thanks,

            Kenny

            • 3. Re: Console Stream looping error with Web Work on Jboss 3.0.
              Kenny Flegal Newbie

              I still had jar files with in the WEB-INF/lib/ folder of the war. I cleared those out because I put them in my lib directory and now everything works great. Which leads to my next question, why does it seem that a problem can not be solved until two minutes after posting a dumb question about it on a forum? :P