2 Replies Latest reply on Nov 11, 2002 12:16 PM by mech

    JSPs work.......Servlets don't :-(

    Lean Mclean Newbie

      Downloaded and installed jboss3.0.3_tomcat-4.1.12
      I know to use Tomcat well.
      So I took a working HelloWorld war file with an index.jsp(which says HelloWorld) and a servlet(which says HelloWorld) and threw it in <jboss-install-dir>/server/default/deploy dir.

      The JSP worked. But the servlet did not.
      I tried other servlets and jsps ...same result!
      Wasted 4 hrs now with this silly thingie:(
      Used the path:-
      http://localhost:8080/servlet/HelloWorld
      (this works on Tomcat stand-alone..and some examples I saw for JBoss used the same path too)

      I have bigger fish to fry (by next weekend). So gotta get moving...So if someone could kindly give me an answer asap would appreciate

        • 1. Re: JSPs work.......Servlets don't :-(
          Lean Mclean Newbie

          Mapping...Mapping ..Mapping!
          I had no mapping for the servlet in my web.xml which I moved from Tomcat. When I added a mapping for the HelloWorld it worked! So JBoss forces one to add all servlets in web.xml, eh?(Now why did Tomcat tolerate that?...(who cares, now:)

          • 2. Re: JSPs work.......Servlets don't :-(
            mech Newbie

            Did you figure out how to get the JNDI naming example servlet working under JBoss/Tomcat?
            I only managed to get it running with Tomcat standalone.

            I guess you also tried to copy the Tomcat's webapps/examples to the JBoss's deploy directory into a examples.war directory for testing, right?

            Everything's fine, even with the servlets (if mapping is done). But for JNDI mapping with respect to the <env-entry>s I just get

            JNDI lookup failed : javax.naming.NameNotFoundException: maxExemptions not bound
            list() on /comp/env Context :
            JNDI lookup failed : javax.naming.NameNotFoundException: not bound

            when I run JndiServlet

            For maxExemptions I guess this is due to the configuration in Tomcat's global files, but for the rest in the web.xml I wonder why I don't get the data...

            Any ideas?