0 Replies Latest reply on Oct 20, 2002 2:15 PM by Jason Boorn

    migrating from 2.4 to 3.0

    Jason Boorn Newbie

      I am having such problems migrating my application from 2.4 to 3.0 that I think there is something fundamentally wrong with what I've done. I am truly at my wits end.

      First of all, it works on 2.4. Well, sort of. The 2.4 JMS has some problems with it, and I was told to migrate to 3.0. But the application works as it is supposed to on 2.4 if you disregard the bugs in the JMS that shipped with 2.4.

      The application has several entity beans and several MDB's. It uses JMS to communicate amongst its various subsystems, and MDB's to process incoming messages. It has a simple sockets server which takes incoming messages and sends them off to the main MessageQueue. From there, they are operated upon and sent to other queues.

      I need to start the socket server as a service, so I have tried many ways of getting this done. Before, I just drop the jar file (which has everything) into the deploy directory, and everything worked great. Now if I do that it wont start the socket server. If I package as a SAR, it wont load the beans.

      I have tried many different things to get this working (see post in Installation and Configuration). When I can get the socket server started, I am consistently getting the following:

      2002-10-20 11:57:46,143 DEBUG [SystemAction.class] checking login
      2002-10-20 11:57:46,153 DEBUG [SystemAction.class] finding by PK
      2002-10-20 11:57:46,163 DEBUG [org.jboss.ejb.plugins.cmp.jdbc.JDBCFindByPrimaryKeyQuery.LoginBean.findByPrimaryKey] Executing SQL: SELECT username FROM LOGINBEAN WHERE username=?
      2002-10-20 11:57:46,193 ERROR [STDERR] java.lang.IllegalAccessError: try to access class myapp.Login from class $Proxy52
      2002-10-20 11:57:46,193 ERROR [STDERR] at $Proxy52.findByPrimaryKey(Unknown Source)
      2002-10-20 11:57:46,203 ERROR [STDERR] at myapp.SystemAction.run(SystemAction.java:222)

      I have seen posts where this happens and people are using separate JARS, but ALL the files of the application are in the same JAR file. What is going on?