3 Replies Latest reply on Oct 29, 2002 2:52 AM by Fusayuki Minamoto

    Win XP - JBOSS 3.0 - Catalina failure

    Mike Rousse Newbie

      Newbie trying to execute scripts handed out in a class using JBOSS 3.0 and Tomcat 4. JBOSS log file indicates 8 errors with Catalina server. Any help would be appreciated.

      Tried to attached JBOSS log but that option apparently doesn't work - I could browse and pick a file but the attach and post button didn't do anything.

      Following is section around first error:
      14:53:21,927 INFO [MainDeployer] Starting deployment of package: file:/C:/java/jboss-3.0/server/default/deploy/tomcat4-service.xml
      14:53:21,947 INFO [MainDeployer] Starting deployment of package: file:/C:/java/jboss-3.0/server/default/deploy/tomcat4-service.jar
      14:53:21,967 INFO [MainDeployer] Successfully completed deployment of package: file:/C:/java/jboss-3.0/server/default/deploy/tomcat4
      -service.jar
      14:53:22,097 ERROR [SARDeployer] create operation failed for package file:/C:/java/jboss-3.0/server/default/deploy/tomcat4-service.xm
      l
      org.jboss.deployment.DeploymentException: instantiating org.jboss.web.catalina.EmbeddedCatalinaServiceSX failed: java.lang.NoClassDef
      FoundError: org/apache/catalina/LifecycleListener; - nested throwable: (RuntimeErrorException: instantiating org.jboss.web.catalina.E
      mbeddedCatalinaServiceSX failed: java.lang.NoClassDefFoundError: org/apache/catalina/LifecycleListener
      Cause: java.lang.NoClassDefFoundError: org/apache/catalina/LifecycleListener)

        • 1. Re: Win XP - JBOSS 3.0 - Catalina failure
          Joel Vogt Master

          this seems like a classpath type conflict. Make sure the classpath isn't set with any extra jars before you start jboss. Set JAVA_HOME and thats it. Jboss startup scripts should do the rest.

          • 2. Re: Win XP - JBOSS 3.0 - Catalina failure
            Mike Rousse Newbie

            I had tried some classpath variations but as you suggest, I deleted the classpath entry in my XP user account. Then tried the JBoss run.bat. At the beginning of the log file, a class path is generated of:
            ;C:\PROGRA~1\JDK13~1.1_0\lib\tools.jar;C:\java\jboss-3.0\bin\\run.jar.
            (the odd "C:\PROGRA~1\JDK13~1.1_0" was required to avoid embedded spaces in the path name).
            This still generated the Catalina errors.

            Elsewhere in this forum I found another reference:
            http://www.jboss.org/modules/bb/index.html?module=bb&op=viewtopic&t=forums/ reference talks about a CATALINA_HOME environmental variable. After discussing it with the teacher of the class, I made the following changes:
            Created an environmental variable in my XP user account of CATALINA_HOME=C:\java\jboss-3.0\catalina
            Then edited the tomcat4-service.xml file to fully specify the path, changing the line
            <!ENTITY catalina.home "../catalina">
            to
            <!ENTITY catalina.home "C:/java/jboss-3.0/catalina">
            I then ran the JBoss run.bat file. None of the catalina errors occurred. I've stopped and started JBoss several times and the errors have not returned. I've tested it with a JSP page and it works. I also rebooted once and restarted it, once again with no catalina errors. I don't know why this should solve the problem but it's running so far. Thanks for your suggestion anyway.

            • 3. Re: Win XP - JBOSS 3.0 - Catalina failure
              Fusayuki Minamoto Apprentice

              This looks just a relative path problem.
              I guess you started jboss not from %JBOSS_HOME%\bin.
              Change directory to %JBOSS_HOME%\bin, then type run.bat.

              Miki