0 Replies Latest reply on Jan 20, 2003 6:02 AM by Irial Conroy

    Problems debugging JBoss-3.0.4 app (with j2sdk1.4.1_01).

    Irial Conroy Newbie

      Hi,

      I am having problems debugging a JBoss-3.0.4 app (with j2sdk1.4.1_01). Are there any general facts\issues regarding debugging with JBoss-3.0.4 /j2sdk1.4.1_01 that I should bear in mind ?

      1) Start JBoss with the following parameters related to debugging

      .....
      rem JPDA options. Uncomment and modify as appropriate to enable remote
      debugging.
      set JAVA_OPTS=-Xdebug -Xnoagent -Djava.compiler=NONE
      -Xrunjdwp:transport=dt_socket,address=8787,server=y,suspend=n
      %JAVA_OPTS%
      .....

      Note: Tried with -classic at first but realised it is not supported anymore

      2) Connect from SunONE IDE(also using j2sdk1.4.1_01)

      - Add breakpoints

      - Attach with the following options
      Debugger Type = Default Debugger (JPDA)
      Connector = SocketAttach
      Transport = dt_socket
      Host = <my machine>
      port = 8787

      - Debugging session running, connected to <my machine>:8787

      - Execute JUnit tests, complete successfully BUT breakpoints NOT hit

      3) Try using different jdks with SunONE

      ...as the following posting suggested that there may be problems using
      j2sdk1.4.1_01 with SunONE :
      http://forum.java.sun.com/thread.jsp?thread=312837&forum=54&message=1349181

      - tried j2sdk1.4.0_01 and jdk1.3.1_02 to no avail - breakpoints still
      not hit


      4) Couldn't find anything in 1.4.1 documentation that would suggest
      that my setup is incorrect...

      http://java.sun.com/j2se/1.4/docs/guide/jpda/conninv.html
      ..seems to tell me that my debugger setings are ok.

      5) Same debug settings worked fine with JBoss-2.4.7 (with jdk1.3.1_02
      )


      So is there something else that I'm missing with regard to debuging using JBoss-3.0.4/j2sdk1.4.1_01 ?

      Thanks in advance,