0 Replies Latest reply on Mar 21, 2003 3:20 PM by Clarke Wood

    JBoss 3.0.6 startup hangs with Sun's JNDI file system servic

    Clarke Wood Newbie

      I am running JBoss 3.0.6 on FreeBSD 4.7-STABLE, using j2sdk 1.3.1-p7. I am attempting to use Sun's JNDI file system service provider (1.2 beta 3).

      I have copied all the file system service provider jars (jndi.jar, providerutil.jar, fscontext.jar) into the server/default/lib directory. I then modified server/default/conf/server.policy as follows:

      grant {
      permission java.security.AllPermission;
      permission java.util.PropertyPermission "*", "read,write";
      permission java.io.FilePermission "<<ALL FILES>>", "read,write,execute,delete";
      };

      I then modified run.sh to pass the following parameters to the VM:
      -Djava.security.manager=java.lang.SecurityManager -Djava.security.policy=../server/default/conf/server.policy

      Before I made this change to run.sh (in other words, before I tried granting file system permissions to the JNDI file system service provider), JBoss would start up properly and everything deployed and worked great. However, once I added in the options to use the server.policy file, JBoss hangs at startup. It outputs the JBoss Bootstrap Environment comment block and then it outputs one line:

      01:01:01,916 INFO [Server] JBoss Release: JBoss-3.0.6 CVSTag=JBoss_3_0_6

      At that point, JBoss hangs and never recovers.

      What am I doing wrong?