8 Replies Latest reply on Apr 3, 2003 2:31 AM by Juha Lindfors

    Is Jboss able to perform in my environment?

    Rolf Schumacher Newbie

      I tried to install jboss 3.06 on Debian linux with kernel 2.4 and <java -version> = 1.4.1.
      This leads to some java exceptions in server.log.
      Then - alternatively - I tried to install jboss 3.2.0RC3 in the same environment. I got much fewer java exceptions.
      Both jboss starts lead to a last log line of "...] Started in 1m:xxs:yyyms".
      URL:8080/jmx_console delivered the correct page.

      Is this now a working environment? An environment with no surprises later on? If NO: how to know that I've got a workin environment? If YES: what to do with those errors?

      Rolf

      p.s.
      the one error with 3.2.0RC3 that I identified in server.log was:

      ...
      ...
      ...
      2003-03-25 17:56:47,448 DEBUG [org.jboss.management.j2ee.factory.WebModuleFactory] Created servlet: jboss.web:Jetty=0,JBossWebApplicationContext=0,context=/invoker,name=ReadOnlyAccessFilter, module: jboss.management.local:J2EEApplication=http-invoker.sar,J2EEServer=Local,WebModule=invoker.war,j2eeType=Servlet,name=ReadOnlyAccessFilter
      2003-03-25 17:56:47,448 DEBUG [org.jboss.management.j2ee.factory.WebModuleFactory] Creating servlet: jboss.web:Jetty=0,JBossWebApplicationContext=0,context=/invoker,HashSessionManager=0
      2003-03-25 17:56:47,448 DEBUG [org.jboss.management.j2ee.Servlet] Could not create JSR-77 Servlet: null
      java.lang.NullPointerException
      at java.util.Hashtable.put(Hashtable.java:389)
      at org.jboss.management.j2ee.J2EEManagedObject.(J2EEManagedObject.java:147)
      at org.jboss.management.j2ee.Servlet.(Servlet.java:88)
      at org.jboss.management.j2ee.Servlet.create(Servlet.java:47)
      at org.jboss.management.j2ee.factory.WebModuleFactory.createServlet(WebModuleFactory.java:110)
      ...
      ...
      ...