1 Reply Latest reply on Apr 21, 2003 1:06 PM by Adrian Brock

    Error deploying on JBoss 3.2.0...

    erikengerd2 Newbie

      Hi,


      I previously used Jboss 2.4.6 where deploying an application was as easy as copying a war file into a directory.

      Now, with JBoss 3.2.0 this approach no longer appears to work. There is however a deployer.sh script but when I start this, I get the following message:

      Exception in thread "main" java.lang.NoClassDefFoundError: org/jboss/deployment/MainDeployerConstants
      at java.lang.ClassLoader.defineClass0(Native Method)
      at java.lang.ClassLoader.defineClass(ClassLoader.java:502)
      at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123)
      at java.net.URLClassLoader.defineClass(URLClassLoader.java:250)
      at java.net.URLClassLoader.access$100(URLClassLoader.java:54)
      at java.net.URLClassLoader$1.run(URLClassLoader.java:193)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(URLClassLoader.java:186)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:299)
      at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:265)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:255)
      at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:315)
      at org.jboss.jmx.service.RemoteDeployer.(RemoteDeployer.java:105)
      at org.jboss.jmx.service.RemoteDeployer.main(RemoteDeployer.java:434)
      j

      Can anyone help me?

      Cheers
      Erik