0 Replies Latest reply on Apr 28, 2003 1:24 AM by Shafei Jomohat

    Need 2 use old version of xerces

    Shafei Jomohat Newbie

      Hi JBoss gurus..

      I noticed that JBoss 3.2.0 comes with Xerces. However, i need to use an older version of Xerces that seems to work with some 3rd party jars that i need. If i have the older version of xerces in my war package, then i get "virtual function call exception"

      If i replace the Xerces that comes together with JBoss with the older version i was using, then it works fine.
      I know this is not the right way to do, but i really dunno how to get past this.

      Has it to got something to do with the classloading ? I got the purchased docs but i still dont understand dat much. I just need to tell JBoss to take the xercers jar file from my war rather than the one from the system. I added this:

      <jboss-web>
      <class-loading java2ClassLoadingCompliance="false"/>
      </jboss-web>

      to my jboss-xml but it didnt help. :(

      Thanks in advance...