6 Replies Latest reply on May 14, 2003 4:37 AM by Dave Head-Rapson

    upgrade to v3.2.1 from v3.0.1

    ben holland Newbie

      Hi,

      Am upgrading and deploying beans that worked on version 3.0.2.
      Now when I call a session bean I get a class not found exception for my value/transport object. This occurs whether the class jar is in the depploy or lib directory.

      Is there any v 3.2.1 documentation that I could scan?
      Has anyone had a similar problem?

      Thanks.
      Ben.

        • 1. Re: upgrade to v3.2.1 from v3.0.1
          ben holland Newbie

          Hello Again,

          I am a bit concerned that nobody is experiencing the same problem. I am running on Win 2000.

          For version 3.0.1 we simply installed a vanilla version of jboss. Placed the required classes in the default lib dir and then deployed our beans to the deploy dir.
          Have even got as far as using cmp and cmr.

          Have scanned through the quickstart guide but nothing stands out.

          I would really appreciate some pointers here. Do my library jars need to be defined in one of the config files?

          Any help welcome.

          Ben

          • 2. Re: upgrade to v3.2.1 from v3.0.1
            Jon Barnett Master

            You probably need to be more explicit about the error you are getting, the classes involved and so on. Perhaps a stacktrace dump of the error, whether it was client-side or server-side, that sort of thing. Unfortunately, as most of us have other things going on, we are sometimes just going to go for the low hanging fruit and answer questions for which answers come easily. ;)

            • 3. Re: upgrade to v3.2.1 from v3.0.1
              ben holland Newbie

              okey dokey,

              Heres the stack trace from jboss.
              11:00:28,825 ERROR [LogInterceptor] Unexpected Error:
              java.lang.NoClassDefFoundError: mvdc/web/benefits/forms/BenefitEntitleForm
              at mvdc.ejb.benefit.BenefitLookupBean.getBenefitSummary(Unknown Source)
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
              java:39)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
              sorImpl.java:25)
              at java.lang.reflect.Method.invoke(Method.java:324)
              at org.jboss.ejb.StatelessSessionContainer$ContainerInterceptor.invoke(S

              I have two ejb jars.

              benReference.jar (entity)
              benLookup.jar (stateless session references benRef and mvdcforms)

              mvdcForms.jar (holds value object)

              Heres the rub. mvdcForms.jar references struts.jar
              (not brilliant design but stay with me)
              The above error is a result of the strats.jar not being
              in the classpath.
              Seems a bit of a misleading error is it a JBoss bug?

              It works now with the struts jar, thanks for making me think a little more about the problem.

              Happy Bunny.


              • 4. Re: upgrade to v3.2.1 from v3.0.1
                Jon Barnett Master

                This is a pure Java stack trace - which has nothing really to do with JBoss. The reason the trace can't tell you anything more is that it is not directly working with the object, but through a reflection.

                • 5. Re: upgrade to v3.2.1 from v3.0.1
                  ben holland Newbie

                  good point in v3.0.1 JBoss cant use reflection I guess
                  because it gives this.

                  13:26:31,215 ERROR [LogInterceptor] Unexpected Error:
                  java.lang.NoClassDefFoundError: org/apache/struts/action/ActionForm
                  at java.lang.ClassLoader.defineClass0(Native Method)
                  at java.lang.ClassLoader.defineClass(ClassLoader.java:509)
                  at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:12
                  3)
                  at java.net.URLClassLoader.defineClass(URLClassLoader.java:246)
                  at java.net.URLClassLoader.access$100(URLClassLoader.java:54)
                  at java.net.URLClassLoader$1.run(URLClassLoader.java:193)
                  at java.security.AccessController.doPrivileged(Native Method)
                  at java.net.URLClassLoader.findClass(URLClassLoader.java:186)
                  at org.jboss.mx.loading.UnifiedClassLoader.findClass(UnifiedClassLoader.
                  java:226)

                  A more exact message.

                  • 6. Re: upgrade to v3.2.1 from v3.0.1
                    Dave Head-Rapson Newbie

                    Make sure you put the jar file with the required class ( org/apache/struts/action/ActionForm ) in the /lib directory of the new installation of JBoss