6 Replies Latest reply on Jun 6, 2003 5:54 AM by Jon Barnett

    JBOSS failed

    hhhh Newbie

      When trying to activate JBOSS:
      #cd /ora/Compiere2/jboss/bin
      #sh run.sh

      It showed an Error about missing jboss-service.xml file.

      so I created a softlink
      #cd /ora/Compiere2/jboss/server/default
      #ln -s /ora/Compiere2/jboss/server/compiere/conf conf

      When run.sh is rerun, warnings messages are displayed:
      ...
      WARN [ServcieConfigurator] Failed to complete install java.lang.ClassNotFoundException:No ClassLoaders found for: org.jboss.varia.property.PropertyEditorManagerService
      ...

      After 19 such warnings, it is followed by an error message:
      ...
      ERROR [Server] start failed
      org.jboss.deployment.DeploymentException:jboss:type=Service,name=BootstrapEditors is not registered.: - nested throwable: (javax.management.InstanceNotFoundException:jboss:type=Service,name=BootstrapEditors is not registered.)
      ...

      How can I resolve this problem? (I'm running Debian Linux)

      Thanks for helping...

        • 1. Re: JBOSS failed
          Jon Barnett Master

          What is the initial output from your run script? It should be something like:

          ================================================================================

          JBoss Bootstrap Environment

          JBOSS_HOME: /usr/local/JBoss-3.2.0

          JAVA: /usr/local/IBMJava2-14/bin/java

          JAVA_OPTS: -Djava.io.tmpdir=/jetty -Dprogram.name=run.sh

          CLASSPATH: /usr/local/JBoss-3.2.0/bin/run.jar:/usr/local/IBMJava2-14/lib/tools.jar

          ================================================================================

          Please post it here as a starting point for diagnosis.

          • 2. Re: JBOSS failed
            hhhh Newbie

            The initial run script output is as follows:
            ================================================================================

            JBoss Bootstrap Environment

            JBOSS_HOME: /ora/Compiere2/jboss

            JAVA: /usr/local/bin/j2sdk1.4.1_01/bin/java

            JAVA_OPTS: -server -Dprogram.name=run.sh

            CLASSPATH: /ora/Compiere2/jboss/bin/run.jar:/usr/local/bin/j2sdk1.4.1_01/lib/tools.jar

            ================================================================================

            • 3. Re: JBOSS failed
              hhhh Newbie

              Subsequent run script output which might be useful for diagnosis:

              08:41:33,058 INFO [Server] JBoss Release: JBoss-3.0.4 CVSTag=JBoss_3_0_4
              08:41:33,363 INFO [Server] Home Dir: /ora/Compiere2/jboss
              08:41:33,385 INFO [Server] Home URL: file:/ora/Compiere2/jboss/
              08:41:33,389 INFO [Server] Library URL: file:/ora/Compiere2/jboss/lib/
              08:41:33,519 INFO [Server] Patch URL: null
              08:41:33,522 INFO [Server] Server Name: default
              08:41:33,526 INFO [Server] Server Home Dir: /ora/Compiere2/jboss/server/default
              08:41:33,531 INFO [Server] Server Home URL: file:/ora/Compiere2/jboss/server/default/
              08:41:33,536 INFO [Server] Server Data Dir: /ora/Compiere2/jboss/server/default/db
              08:41:33,540 INFO [Server] Server Temp Dir: /ora/Compiere2/jboss/server/default/tmp
              08:41:33,546 INFO [Server] Server Config URL: file:/ora/Compiere2/jboss/server/default/conf/
              08:41:33,550 INFO [Server] Server Library URL: file:/ora/Compiere2/jboss/server/default/lib/
              08:41:33,554 INFO [Server] Root Deployemnt Filename: jboss-service.xml
              08:41:33,667 INFO [Server] Starting General Purpose Architecture (GPA)...
              08:41:37,078 INFO [ServerInfo] Java version: 1.4.1_01,Sun Microsystems Inc.
              08:41:37,082 INFO [ServerInfo] Java VM: Java HotSpot(TM) Server VM 1.4.1_01-b01,Sun Microsystems Inc.
              08:41:37,087 INFO [ServerInfo] OS-System: Linux 2.4.20-bf2.4,i386
              08:41:38,115 INFO [ServiceController] Controller MBean online
              08:41:39,131 INFO [MainDeployer] Creating
              08:41:39,450 INFO [MainDeployer] Created
              08:41:39,461 INFO [MainDeployer] Starting
              08:41:39,467 INFO [MainDeployer] Started
              08:41:39,728 INFO [JARDeployer] Creating
              08:41:39,732 INFO [JARDeployer] Created
              08:41:39,738 INFO [JARDeployer] Starting
              08:41:39,743 INFO [MainDeployer] Adding deployer: org.jboss.deployment.JARDeployer@1d9fd51
              08:41:39,836 INFO [JARDeployer] Started
              08:41:40,036 INFO [SARDeployer] Creating
              08:41:40,039 INFO [SARDeployer] Created
              08:41:40,043 INFO [SARDeployer] Starting
              08:41:40,048 INFO [MainDeployer] Adding deployer: org.jboss.deployment.SARDeployer@1edc073
              08:41:40,868 INFO [SARDeployer] Started
              08:41:40,871 INFO [Server] Core system initialized
              08:41:41,006 INFO [MainDeployer] Starting deployment of package: file:/ora/Compiere2/jboss/server/default/conf/jboss-service.xml
              08:41:43,302 WARN [ServiceConfigurator] Failed to complete install
              java.lang.ClassNotFoundException: No ClassLoaders found for: org.jboss.varia.property.PropertyEditorManagerService
              ...

              • 4. Re: JBOSS failed
                Jon Barnett Master

                OK. The environment looks fairly normal for a Linux JDK 1.4.1 result.

                Can you explain why you create a link to a JBoss compiere instance?

                Normally, there should already exist a server/default/conf directory. If you could revert to the standard distribution and we can have a look at the server.log from this when you run it, that might be helpful. Also, with the standard distribution, try just:
                ./run.sh

                I wouldn't expect anything to be different there, but let's try to minimise differences.

                • 5. Re: JBOSS failed
                  hhhh Newbie

                  The link was created because 'conf' was not in ../server/default directory.

                  My JBOSS was installed automatically when I installed Compiere. Should 'conf' folder have existed in the directory?

                  • 6. Re: JBOSS failed
                    Jon Barnett Master

                    There should definitely have been a conf directory, a lib directory, a log directory and a deploy directory in default. There should probably be a data directory for housing the hypersonic database that ships by default with JBoss. So it is a bit worrying that you didn't have the default conf which sets up much of the standard bootstrap services.

                    Try getting a clean JBoss 3.2.x distribution so at least we know the configs are ok out of the box, so to speak.