6 Replies Latest reply on Oct 9, 2003 7:57 AM by Adrian Brock

    JBoss API

    terablot Newbie

      How do I get JBoss API (javadoc)? It doesn't seems to be located in the doc directory of the distribution and a seach in the build file does not seems to make use of ant's javadoc task.

      Thanks in advance

        • 1. Re: JBoss API
          terablot Newbie

          could anyone kindly shed some light on this issue please? Thanks :-)

          • 2. Re: JBoss API
            Vishal Sharma Expert

            I am also curious to know whether the JBOSS API docs live.
            I use eclispe so i can see the apis throght the help in editor, but with security onJboss i want to know what are the variosu apis available.
            Can anyone pleas point me where the docs api are availabale for JBOSS.

            • 3. Re: JBoss API
              Adrian Brock Master

              Download the source distribution and run
              ./build.sh all
              in the module where you want the javadoc

              Regards,
              Adrian

              • 4. Re: JBoss API
                Christian Dalager Newbie

                When I try to generate javadocs for jboss-head with
                ./build.sh all
                Ant throws a 'build failed' when it gets to the javadoc target, complaining that

                File:C:/JBoss4/src/jboss-head/common/../tools/etc/buildmagic/buildmagic.ent:546:
                C:\JBoss4\src\jboss-head\common\${source.classes} not found.

                Any solutions or pointers?
                "./build.sh docs" gives me the same result.

                Regards
                Christian Dalager

                • 5. Re: JBoss API
                  Vishal Sharma Expert

                  I downloaded the Jboss-3.2.1 src and build it , that worked fine.
                  But u are using Jboss.4.0, which is still under development, I'm not sure whether u can build the docs successfully though.
                  One would hope it works.

                  Vishal.

                  • 6. Re: JBoss API
                    Adrian Brock Master

                    Modify the file mentioned to have the following
                    around the line number reported:



                    <javadoc packagenames="${javadoc.packages}"
                    sourcepath="${source.java}:${module.output}/gen-src"

                    I've fixed this is cvs.

                    Regards,
                    Adrian