3 Replies Latest reply on Sep 26, 2003 5:54 AM by lcekov

    Running JBoss on Aix

    lcekov Newbie

      Hello every body.
      I have used JBoss for a long time without problems on Windows operational systems but now I am trying to run it on Aix.
      I extracted the Jboss3.2.1 zip an than I tryed to run it but an exception was throwen:

      ERROR [WebService] Starting failed
      java.net.BindException: The socket name is not available on this system.
      at java.net.PlainSocketImpl.socketBind(Native Method)
      at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:430)
      at java.net.ServerSocket.(ServerSocket.java:191)
      at org.jboss.web.WebServer.start(WebServer.java:169)
      at org.jboss.web.WebService.startService(WebService.java:286)
      at org.jboss.system.ServiceMBeanSupport.start(ServiceMBeanSupport.java:192)
      at java.lang.reflect.Method.invoke(Native Method)
      at org.jboss.mx.capability.ReflectedMBeanDispatcher.invoke(ReflectedMBeanDispatcher.java:284)
      at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java(Compiled Code))
      at org.jboss.system.ServiceController$ServiceProxy.invoke(ServiceController.java:966)
      at $Proxy0.start(Unknown Source)
      at org.jboss.system.ServiceController.start(ServiceController.java:392).......

      Does anyone had the same problem before.
      How can I solve it?

        • 1. Re: Running JBoss on Aix
          Jon Barnett Master

          It looks like you could not bind the web server port for the servlet container. This either means you tried to bind to a port lower than 1024 and don't have the permissions i.e. you are not root; or if you have not touched the connector port configuration, port 8080 is already taken by some other program.

          • 2. Re: Running JBoss on Aix
            lcekov Newbie

            Thank you for your raply.
            The problem is not in the WebServer but in webService.
            Jetty binds very well on 8080 because i can connect to /jmx-console after the servet started on.

            I do not have an idea what could be the problem.
            The webService listens on 8083 by default . I change it to some other port (8283) for test but the result was the same. Than i put Naming service to listen on the same port (8283) and it was ok , but the WebService still throws the same exception. Note that WebService starts befor namingService and if it starts well the problems must be in NamingServise.
            If you have some sugestions on it plese write tham.

            • 3. Re: Running JBoss on Aix
              lcekov Newbie

              I found what was the problem.
              The host for binding of the webService has been wrong. I don't know what wad the value f the binding host string , but when i set it to localhost i jboss-servise.xml everithing was all right.