1 Reply Latest reply on Nov 21, 2003 2:50 AM by asinitsyn

    Problems starting jboss 4.0 on XP

    Philip Harvey Newbie

      I downloaded JBoss 4.0 and tried running it on XP. Yes yes, I know I should have stuck to the production-ready version, but I couldn't resist...

      Anyway, run.bat gave me SocketExceptions - see the log excerpt at the bottom of this message.

      I wasn't sure if these were important or not, but I reckon they probably were because I had problems when I tried testing the first example from the O'Reilly workbook :-( The JNDI service complained that the Cabin bean was not registered.

      I've used WebLogic before, but not JBoss. Any advice gratefully received!

      Log excerpt:
      2003-10-10 19:21:28,800 DEBUG [org.jboss.management.j2ee.factory.ServiceModuleFactory] Create MBean, name: jboss.remoting:service=InterceptorAdapter, SAR Module: jboss.management.local:J2EEServer=Local,j2eeType=ServiceModule,name=remoting-service.xml
      2003-10-10 19:21:28,800 DEBUG [org.jboss.system.ServiceController] starting service jboss.remoting:service=Detector,transport=multicast
      2003-10-10 19:21:28,910 WARN [org.jboss.system.ServiceController] Problem starting service jboss.remoting:service=Detector,transport=multicast
      java.net.SocketException: error setting options
      at java.net.PlainDatagramSocketImpl.join(Native Method)
      at java.net.PlainDatagramSocketImpl.join(PlainDatagramSocketImpl.java:134)
      at java.net.MulticastSocket.joinGroup(MulticastSocket.java:274)