3 Replies Latest reply on Jan 13, 2004 11:20 AM by micke

    JBoss 3.2.3 redeploy runs previous classes also if I restart

    mauro63 Newbie

      Hi,

      This is a very wierd issue, I have deployed an exploded war into jboss-3.2.3/server/default/deploy it works fine.
      If I modify a jsp, it redeploys correctly, however if I modify a servlet or any other java class in WEB-INF/classes jboss keeps running the old one.

      The very wierd issue is that jboss keeps running the old classes even if I restart jboss, or if I remove completely the application war and replace it with one that definately contains the new classes and of course, I stop and restart jboss.

      The only way to refresh my application is to erase completely the jboss installation and restart from the beginning.

      This isn't really working, am I doing something wrong?

      Running on Linux SuSe 9, JBoss 3.2.3, Sun jdk 1.4.2_02-b03

      Thank you.

        • 1. Re: JBoss 3.2.3 redeploy runs previous classes also if I res
          micke Novice

          I recall having some problems with old class definitions being used instead of new ones. I set "UseJBossWebLoader" to false in jboss-service.xml in the web sar. That solved it for me. I had almost forget about this issue. I will investigate this further in my setup when I got some time to figure out if I have a bad config or if this is a new "feature".

          • 2. Re: JBoss 3.2.3 redeploy runs previous classes also if I res
            mauro63 Newbie

            Thank you for your message, I have tried it, same result. The only way to see my new classes is to REINSTALL jboss -> reconfigure -> redeploy. The funny thing is that once jboss is stopped all tmp stuff is removed. I searched through the whole jboss-3.2.3 tree and found nothing like a class file left behind (but here we are in the "I do not know what else to do hacking mode").

            This is a serious issue because being able to refresh a deployment is fundamental whilst developing. Re-Installing JBoss to see the new application version is not an option.

            Is anyone else experiencing the same problem?

            M.

            • 3. Re: JBoss 3.2.3 redeploy runs previous classes also if I res
              micke Novice

              I fell into the UCL pit. I included an old war in my deploy dir that hold an old version of a common jar. Its gone and it works as supposed to with UseJBossWebLoader set to true. Maybe you want browse all your deployments just to double-check.

              Can you see anything in the log file indicating that the deployment scanner notice a change?

              Do you the same behaviour if you shutdown JBoss and delete default/tmp and default/work dirs?