1 Reply Latest reply on Feb 12, 2004 9:31 AM by csmmoss

    JBoss3.2.3 vs. JBoss3.2.1

    tsangcn Newbie

      Hello,

      My application runs no problem in JBoss 3.2.1 (with Jetty). In JBoss3.2.3 (with Jetty), it deploys OK. But as I access a JSP page, it always failed with strange exceptions, such as LinkageError in javax.servlet.jsp.tagext.Tag, ClassCastException in TagHandlerPool, ... I have tried about a hundred times, and suddently it runs OK in 2 times. I suspected that this is due to a difference in classloader structure between the 2 versions of JBoss. So I am totally helpless and it seems that my application cannot go beyond JBoss 3.2.1.

      Furthremore, I have tried JBoss 3.2.3 with Tomcat, and I have tried setting UseJBossWebLoader=true, but it gives no hope.

      Anyone can help me? Thanks a lot.

      C. N.

        • 1. Re: JBoss3.2.3 vs. JBoss3.2.1
          csmmoss Newbie

          Not that I can offer any help, just some company...

          We've only just upgraded from 3.2.1 to 3.2.3 (both with jetty), ourselves, and are experiencing many strange errors in our jUnit tests. They run fine under 3.2.1 (with Cactus), but are failing all over the place under 3.2.3 (& 3.2.2).

          We're also searching for a list of changes between the versions.

          Logan