0 Replies Latest reply on Feb 26, 2004 10:54 AM by nerotnt

    HELP! Can't configure CMT in JBoss 3.2.3

    nerotnt Newbie

      Don't know where to look anymore.
      I have a Session Bean with the following ejb-jar.xml:

      <?xml version="1.0" encoding="UTF-8"?>
      <!DOCTYPE ejb-jar PUBLIC "-//Sun Microsystems, Inc.//DTD Enterprise JavaBeans 2.0//EN" "http://java.sun.com/dtd/ejb-jar_2_0.dtd">
      
      <ejb-jar >
      
       <description><![CDATA[No Description.]]></description>
       <display-name>Generated by XDoclet</display-name>
      
       <enterprise-beans>
      
       <!-- Session Beans -->
       <session >
       <description><![CDATA[EJB Test]]></description>
      
       <ejb-name>MpBean</ejb-name>
      
       <home>pt.ejb.MpHome</home>
       <remote>pt.ejb.Mp</remote>
       <local-home>pt.ejb.MpLocalHome</local-home>
       <local>pt.ejb.MpLocal</local>
       <ejb-class>pt.ejb.MpBean</ejb-class>
       <session-type>Stateless</session-type>
       <transaction-type>Container</transaction-type>
      
       </session>
      
       <!-- Entity Beans -->
      
       <!-- Message Driven Beans -->
      
       </enterprise-beans>
      
       <!-- Relationships -->
      
       <!-- Assembly Descriptor -->
       <assembly-descriptor >
      
       <!-- finder permissions -->
      
       <!-- transactions -->
       <container-transaction >
       <method >
       <ejb-name>MpBean</ejb-name>
       <method-name>*</method-name>
       </method>
       <trans-attribute>Required</trans-attribute>
       </container-transaction>
      
       <!-- finder transactions -->
       </assembly-descriptor>
      
      </ejb-jar>
      


      My objective is to use CMT.
      The SB gets deployed successfully and when I execute a SB method it gives no error.
      But no changes are made to the DB! That's my problem. Looks to me that no "commit" is being done.
      Is there another file that I need to configure besides ejb-jar.xml to enable CMT?

      Really need help on this. Giving me headaches.