0 Replies Latest reply on Apr 1, 2004 8:01 PM by rasoul

    InvalidableEntityInstanceCache Error

    rasoul Newbie

      Hello all,
      I am using JBoss 3.2.3. But when I try to set my instance-cache
      I get the following error:

      state: FAILED
      I Depend On:
      Depends On Me: org.jboss.deployment.DeploymentException: Missing or invalid Instance Cache (in jboss.xml or standardjboss.xml); - nested throwable: (java.lang.ClassNotFoundException: No ClassLoaders found for: org.jobss.ejb.plugins.InvalidableEntityInstanceCache)]

      And here is my jboss.xml
      <container-configurations>
      <container-configuration>
      <container-name>LRU Configuration</container-name>
      <instance-pool>org.jobss.ejb.plugins.EntityInstancePool</instance-pool>
      <instance-cache>org.jobss.ejb.plugins.InvalidableEntityInstanceCache</instance-cache>
      <container-cache-conf>
      <cache-policy>org.jobss.ejb.plugins.LRUEnterpriseContextCachePolicy</cache-policy>
      <cache-policy-conf>
      <min-capacity>50</min-capacity>
      <max-capacity>100000</max-capacity>
      <overager-period>300</overager-period>
      <max-bean-age>600</max-bean-age>
      <resizer-period>400</resizer-period>
      <max-cache-miss-period>60</max-cache-miss-period>
      <min-cache-miss-period>1</min-cache-miss-period>
      <cache-load-factor>0.75</cache-load-factor>
      </cache-policy-conf>
      </container-cache-conf>
      <container-pool-conf>
      100
      </container-pool-conf>
      </container-configuration>
      </container-configurations>

      Can anyone tell me what I may be doing wrong.
      Thanks in advance
      -r