3 Replies Latest reply on Apr 30, 2004 3:49 PM by Erik Hansen

    run xdoclet error

    pjrichter Newbie

      I'm working on my first JBoss project and had successfully deployed and tested 2 ejb's. I'm using jboss-3.2.3RC1 with the Eclipse IDE. I tried to rerun the xdoclet build to add a new ejb, and received this error:

      BUILD FAILED: file:C:/eclipse/workspace/Fascor/xdoclet-build.xml:17: taskdef class xdoclet.modules.ejb.EjbDocletTask cannot be found

      I've tried everything from reentering my xdoclet configuration to rebuilding the entire project folder by folder but can't get by this error. Here's my xdoclet-build.xml file.

      <?xml version="1.0" encoding="UTF-8" ?>
      - <project default="_generation_" name="XDoclet Generator">
      - <path id="xdoclet.classpath">
       <pathelement location="bin" />
       <pathelement location="../shared/bin" />
       <pathelement location="C:/jboss-3.2.3RC1/client/jboss-j2ee.jar" />
       <pathelement location="C:/jboss-3.2.3RC1/server/default/lib/javax.servlet.jar" />
       <pathelement location="C:/jboss-3.2.3RC1/server/default/lib/classes12.zip" />
       <pathelement location="C:/jboss-3.2.3RC1/server/default/lib/emobj.jar" />
       <pathelement location="C:/jboss-3.2.3RC1/server/default/lib/jtds-0.5.jar" />
      - <fileset dir="">
       <include name="*.jar" />
       </fileset>
       </path>
       <target name="_generation_" depends="N10004,N102CB" />
      - <target name="N10004" description="ejb">
       <taskdef classpathref="xdoclet.classpath" classname="xdoclet.modules.ejb.EjbDocletTask" name="ejbdoclet" />
      - <ejbdoclet ejbSpec="2.0" destDir="src">
       <fileset dir="src" includes="**/*Bean.java" />
       <deploymentdescriptor destDir="src/META-INF" />
       <jboss Version="3.0" destDir="src/META-INF" />
       <packageSubstitution packages="ejb" substituteWith="interfaces" />
       <remoteinterface />
       <homeinterface />
       </ejbdoclet>
       </target>
      - <target name="N102CB" description="web">
       <taskdef classpathref="xdoclet.classpath" classname="xdoclet.modules.web.WebDocletTask" name="webdoclet" />
      - <webdoclet destDir="src/WEB-INF">
       <fileset dir="src" includes="**/*Servlet.java" />
       <deploymentdescriptor Servletspec="2.3" />
       <jbosswebxml Version="3.0" />
       </webdoclet>
       </target>
       </project>
      Thanks for any help you can offer.



        • 1. Re: run xdoclet error
          Darran Lofthouse Master

          Your xdoclet.class.path does not appear to reference any xdoclet jars unless they are supposed to be picked up by the bottom fileset.

          Has this build script worked before?

          • 2. Re: run xdoclet error
            pjrichter Newbie

            I don't know how to answer, because I never really looked at it when it was working. I did compare it to the xdoclet-build.xml of another project I had been using to test JBoss, and that one had no references to xdoclet jars either, and that one works. Other than the classpath, I can see no differences between them.

            • 3. Re: run xdoclet error
              Erik Hansen Newbie

              Are you running Ant from within Eclipse or outside the IDE in a shell?

              If you're running it inside the IDE, check your classpath settings in Eclipse -- also try and run ant in a shell instead of the IDE.

              Otherwise, you need something in your classpath to pick up the Xdoclet jars.

              <!-- XDoclet classpath for the XDoclet Tasks -->