2 Replies Latest reply on May 10, 2004 7:28 PM by Perry McCarty

    waiting for lock in CVS?

    Perry McCarty Newbie

      I am trying to use CVS for the first time and tried to get a copy of the JBoss_3_2 branch. It seemed to be working just fine until I got stuck with the message:

      cvs server: [] waiting for kimptoc's lock in /cvsroot/jboss/jbosstest/src/resources/bankiiop/META-INF

      This message appeared every 30 seconds for about an hour until the checkout was aborted.

      The troubleshooting section of the manual "Open Source Dev with CVS" says that this can mean that a CVS process failed to clean up after itself. It says that, if so, the solution is to remove the lock file #cvs.lock by hand. I see that file when I peer through the web browser at the repository, but don't know how to go about correcting this.

      Is this a problem that should be reported? Or, do I just wait and try again another day? Who, if anyone, should be contacted?


        • 1. Re: waiting for lock in CVS?
          Raja Master

          I have had thsi in my organisation. Its something funky with the cvs pserver and usually gets resolved in about a few minutes. Did u try checking it out again to see if it can checkout the code?
          Even if u are filing a bug for it, it shud be with Sourceforge!!

          • 2. Re: waiting for lock in CVS?
            Perry McCarty Newbie

            Thanks for the info. I came back a day later and found the offending lock file was no longer there. I tried an update command and it completed this time.

            I have no idea whether the lock indicated that I tried to do an update in the middle of someone else's checkin and that the message indicated correct behavior, or whether there was an errant lockfile that someone else managed to eliminate. Anyway, it's working for me now...