2 Replies Latest reply on Jun 3, 2004 3:55 PM by buka

    bind error while trying tusc tutorial

    jagathig Newbie

      I have been doing chap 3 of TUSC tutorial.
      I am getting the javax.naming.NameNotFoundException: StoreAccessBean not bound error.
      I see that a couple of people have already posted the same problem. I tried redeploying , or editing the ejb-jar.xml and jboss.xml to remove the resource-ref tag , basically tried what they have tried to make it work, yet I am getting this error.
      Can somebody please help me ?

        • 1. Re: bind error while trying tusc tutorial
          Juha Lindfors Master

          Go to your jmx-console, find the JNDIView MBean, and invoke its 'list' operation. Scroll down to the 'Global' section and you'll find all the names accessible to a client. If StoreAccessBean is not listed there, it cannot be found.

          Then go through your ejb-jar.xml and jboss.xml and find what is the actual name you're bind your bean under. This name will also be shown in your 'Global' JNDI name tree. Use that name for the lookup instead.

          • 2. Re: bind error while trying tusc tutorial
            buka Newbie

            I had similar problem while trying to go through the tutorial. Here is the solution that I found.

            When you start jboss 3.2.1 from the command line it will start "default" server. When you run from eclipse/lomboz it will start "all" server. So when you deploy inside eclipse/lomboz you deploy to "all" server.

            To fix it, correct jboss321all.server file (the one that you got from TUSC site located in plugins folder).

            Correct deployment paths to "server/default/deploy"
            and -c default

            Redeploy and try your client.

            Hope it helps,
            Buka.