3 Replies Latest reply on Jul 2, 2005 9:20 PM by Scott Stark

    UnsupportedClassVersionError

    Ilia Maizel Newbie

      Getting this when trying to start up run.bat:


      ===============================================================================
      .
      JBoss Bootstrap Environment
      .
      JBOSS_HOME: E:\jboss\bin\\..
      .
      JAVA: c:\jdk1.3.1_02\bin\java
      .
      JAVA_OPTS: -Dprogram.name=run.bat -Xms128m -Xmx512m
      .
      CLASSPATH: c:\jdk1.3.1_02\lib\tools.jar;E:\jboss\bin\\run.jar
      .
      ===============================================================================
      .
      Exception in thread "main" java.lang.UnsupportedClassVersionError: org/jboss/Mai
      n (Unsupported major.minor version 48.0)
      at java.lang.ClassLoader.defineClass0(Native Method)
      at java.lang.ClassLoader.defineClass(ClassLoader.java:493)
      at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:11
      1)
      at java.net.URLClassLoader.defineClass(URLClassLoader.java:248)
      at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
      at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:299)
      at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:286)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:255)
      at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:315)
      Press any key to continue . . .
      E:\jboss\bin>

      We are using JBoss 4.0.0, OS is Windows 2000, JDK 1.3.1.
      Anyone know what the problem is? Thanks.