1 Reply Latest reply on Sep 27, 2004 3:28 PM by Christopher Miles

    Why does JBoss 4 ignore the

    Christopher Miles Newbie

      I'm using JBoss 4 and I've set the HTTP invoker to use the hostname of the machine in the jboss-services.xml at server/all/deploy/hhtp-invoker.sar/META-INF. Nonetheless, when clients connect we see debug output like this...

      11:38:54,004 DEBUG Util:70 - httpsConnClass: class javax.net.ssl.HttpsURLConnection
      11:38:54,567 DEBUG SpyConnectionFactoryObjectFactory:41 - Extracting SpyConnectionFactory from reference
      11:38:54,672 DEBUG SpyConnectionFactoryObjectFactory:49 - The GenericConnectionFactory is: GenericConnectionFactory[server=org.jboss.mq.il.http.HTTPServerIL@8a6fc connectionProperties={org.jboss.mq.il.http.restinterval=0, org.jboss.mq.il.http.url=http://192.168.2.3:8080/jbossmq-httpil/HTTPServerILServlet, PingPeriod=0, org.jboss.mq.il.http.timeout=60000, ClientILService=org.jboss.mq.il.http.HTTPClientILService}]
      11:38:54,722 DEBUG Connection:201 - Setting the clockDaemon's thread factory
      11:38:54,767 DEBUG HTTPClientILService:148 - Sending a request to 'http://192.168.2.3:8080/jbossmq-httpil/HTTPServerILServlet' for ClientIL #102.

      You can clearly see that it is passing out an IP address. Is there another configuration file that I need to change to get this to work?

      Thank you,
      -- Miles