1 Reply Latest reply on Oct 12, 2004 4:32 PM by Alan Moor

    jboss examples & errors

    pgajria Newbie

      as per an earlier post im still unable to get the tutorial 1.3.0 example
      working correctly

      so i decided to write my own example
      & now im running into the following error
      same as the jboss example error

      in my servlets init()
      unable to lookup "java:/comp/env/foo"
      where foo would be Fibo or any other ejb you create

      now i get the exact same error on 3 different platforms
      os x (jdk 1.4.2), linux(jdk 1.5) & win2000 (jdk's 1.4.2 & 1.5)
      note: these tests were run by 3 different people on different machines

      eclipse -3.0.1
      jboss-ide-3.0.1
      jboss-3.2.5

      at this point im not sure whats causing the error as
      i can clearly see my bean in the jmx-console

      now i have been able to get my example to work once
      after that i added a new business method in the ejb & ran
      the packaging again & it never worked after that
      same jndi error when trying to invoke the servlet

      it ran once after i had rebooted. so much for jboss's hot deploy
      feature

      the Fibo example has never worked.

      is anyone else running into a similar situation & is there a workaround
      or is this a bug in 3.2.5
      i find it odd that a basic tutorial wont work across different machines

      again any replies would be appreciated.

      pete

      btw is there a problem with the forums ?
      i cant login with konquerer or safari
      i keep getting tossed back to the main jboss page