1 Reply Latest reply on Nov 23, 2004 1:08 AM by Darran Lofthouse

    JSPs not compiling in jboss

    Teja Chaitanya Newbie

      Hai everybody,
      I am a new user to jboss. I started working on jboss a few days before and had succeeded in creating a project and a .ear file. i had placed an index.jsp. I had also included some ejbs also which are also deploying good. When i am using http://localhost:9090 my application is detecting as default and my index.jsp is also called as intended but the problem is my index.jsp is not compiling and is giving compiling errors. A java.util.zip exception is encountered. After this i tried to compile some jsp in the my.war(As i created) and also same problem there. After this i checked whether the http://localhost:8080/jmx-console the problem is there for that also as it is also a jsp page. can anybody help me out here. I got strck here for the past three days. I had read all the availble documentation(Ok. Atleast what i got) and still no use for me.

      Thank u guys in advance...

        • 1. [Microsoft][SQLServer 2000 Driver for JDBC]Error establishin
          Darran Lofthouse Master

          Hi,

          For two days I have been trying to itegrate my application (deployed to JBoss) with MS SQLSERVER 2000.

          I have completed the following steps:

          1) set properties in ms-sqlservice.xml (server/default/deploy).
          I have set the JNDI name (in every applicable place) and I have the correct Connection URL and properties.

          2) I put the 3 jars for the MS SQL SERVER 2000 DRIVER for JDBC in the appropriate /lib dir (/server/default/conf and /server/all/conf).

          3) I have updated all the standardjaws.xml and standardjbosscmp-jdbc.xml (with <type-mapping>MS SQLSERVER2000</type-mapping> and <datasource-mapping>MS SQLSERVER2000</datasource-mapping> respectively).

          I have checked my MSSQLServer for settings (The port is set to 1433 which I have specified in the ConnectionURL and TCP/IP is enabled on that port).

          I'm actually not running it over the network at this stage and just trying to get this to work on localhost.

          I keep getting the following error message:

          "uk.police.scottish.common.ejb.modelcache.ModelCacheException: Can't create a connection to the data-tier.
          nested:
          uk.police.scottish.common.util.UtilityException: Failed to get a DB connection
          nested:
          org.jboss.util.NestedSQLException: Could not create connection; - nested throwable: (java.sql.SQLException: [Microsoft][SQLServer 2000 Driver for JDBC]Error establishing socket.); - nested throwable: (org.jboss.resource.ResourceException: Could not create connection; - nested throwable: (java.sql.SQLException: [Microsoft][SQLServer 2000 Driver for JDBC]Error establishing socket.))"

          I really cant think (or just dont know) what else I should be doing.

          Please help!!

          Thanks :)