0 Replies Latest reply on Dec 27, 2004 11:12 AM by Tally Tsabary

    JBoss AOP pointcut issues

    Tally Tsabary Newbie

      Hello,

      I used the AOP to intercept my web-service specific bean and it worked fine.

      Then I changed the *-aop.xml as follows:

      <aop>
      
       <bind pointcut="execution(* *->*(..))">
       <interceptor class="com.test.TestInterceptor"/>
       </bind>
      </aop>


      I restarted the JBoss, but looking at it log i found out the following:

      2004-12-27 17:42:53,216 DEBUG [org.jboss.system.ServiceController] starting service jboss.aop:service=AspectDeployer
      2004-12-27 17:42:53,216 DEBUG [org.jboss.aop.deployment.AspectDeployer] Starting jboss.aop:service=AspectDeployer
      2004-12-27 17:42:53,216 DEBUG [org.jboss.deployment.MainDeployer] Adding deployer: org.jboss.aop.deployment.AspectDeployer@5f2db0
      2004-12-27 17:42:53,216 DEBUG [org.jboss.aop.deployment.AspectDeployer] Started jboss.aop:service=AspectDeployer
      2004-12-27 17:42:53,216 DEBUG [org.jboss.system.ServiceController] Starting dependent components for: jboss.aop:service=AspectDeployer dependent components: []
      2004-12-27 17:42:53,216 DEBUG [org.jboss.mx.loading.RepositoryClassLoader] Added url: file:/D:/jboss-4.0.0/server/default/tmp/aopdynclasses/ucl33065/?dynamic=true, to ucl: org.jboss.mx.loading.UnifiedClassLoader3@d0af9b{ url=file:/D:/jboss-4.0.0/server/default/tmp/deploy/tmp33060jboss-service.xml ,addedOrder=2}
      2004-12-27 17:43:28,608 DEBUG [org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread] Shutdown
      2004-12-27 17:43:28,608 DEBUG [org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread] Notified to shutdown
      2004-12-27 17:43:28,608 INFO [org.jboss.system.server.Server] JBoss SHUTDOWN: Undeploying all packages
      2004-12-27 17:43:28,608 DEBUG [org.jboss.deployment.MainDeployer] Undeploying file:/D:/jboss-4.0.0/server/default/deploy/jboss-aop.deployer/
      2004-12-27 17:43:28,608 DEBUG [org.jboss.deployment.SARDeployer] undeploying document file:/D:/jboss-4.0.0/server/default/deploy/jboss-aop.deployer/
      2004-12-27 17:43:28,608 DEBUG [org.jboss.deployment.SARDeployer] stopping mbean jboss.aop:service=AspectDeployer
      2004-12-27 17:43:28,608 DEBUG [org.jboss.system.ServiceController] stopping service: jboss.aop:service=AspectDeployer
      2004-12-27 17:43:28,608 DEBUG [org.jboss.system.ServiceController] stopping dependent services for: jboss.aop:service=AspectDeployer dependent services are: []
      2004-12-27 17:43:28,608 DEBUG [org.jboss.aop.deployment.AspectDeployer] Stopping jboss.aop:service=AspectDeployer


      What am I doing wrong?
      Does my pointcut definition caused that? -
      I tested it several times (switching between the *-aop.xml) and it always happening.

      Thank you,
      SuDing