2 Replies Latest reply on Feb 14, 2005 8:09 AM by Gurumurthy Ramamurthy

    JBOSS booting problem

    Gurumurthy Ramamurthy Newbie


      Hi,

      when I start jboss (bin/run.bat), i get the following error.
      C:\jboss-3.2.2\bin>run
      ===============================================================================
      .
      JBoss Bootstrap Environment
      .
      JBOSS_HOME: C:\jboss-3.2.2\bin\\..
      .
      JAVA: C:\jdk1.5.0\bin\java
      .
      JAVA_OPTS: -Dprogram.name=run.bat
      .
      CLASSPATH: ;C:\jdk1.5.0\lib\tools.jar;C:\jboss-3.2.2\bin\\run.jar
      .
      ===============================================================================
      .
      16:24:24,806 INFO [Server] Starting JBoss (MX MicroKernel)...
      16:24:24,806 INFO [Server] Release ID: JBoss [WonderLand] 3.2.2 (build: CVSTag=
      JBoss_3_2_2 date=200310182216)
      16:24:24,806 INFO [Server] Home Dir: C:\jboss-3.2.2
      16:24:24,806 INFO [Server] Home URL: file:/C:/jboss-3.2.2/
      16:24:24,806 INFO [Server] Library URL: file:/C:/jboss-3.2.2/lib/
      16:24:24,806 INFO [Server] Patch URL: null
      16:24:24,806 INFO [Server] Server Name: default
      16:24:24,806 INFO [Server] Server Home Dir: C:\jboss-3.2.2\server\default
      16:24:24,806 INFO [Server] Server Home URL: file:/C:/jboss-3.2.2/server/default
      /
      16:24:24,806 INFO [Server] Server Data Dir: C:\jboss-3.2.2\server\default\data
      16:24:24,806 INFO [Server] Server Temp Dir: C:\jboss-3.2.2\server\default\tmp
      16:24:24,806 INFO [Server] Server Config URL: file:/C:/jboss-3.2.2/server/defau
      lt/conf/
      16:24:24,806 INFO [Server] Server Library URL: file:/C:/jboss-3.2.2/server/defa
      ult/lib/
      16:24:24,806 INFO [Server] Root Deployemnt Filename: jboss-service.xml
      16:24:24,822 INFO [Server] Starting General Purpose Architecture (GPA)...
      Failed to boot JBoss:
      javax.management.InstanceNotFoundException: JMImplementation:service=LoaderRepos
      itory,name=Default
      at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.getMBean(Defaul
      tMBeanServerInterceptor.java:1010)
      at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke(DefaultM
      BeanServerInterceptor.java:804)
      at com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(JmxMBeanServer.java:784
      )
      at org.jboss.system.server.ServerImpl.initBootLibraries(ServerImpl.java:
      499)
      at org.jboss.system.server.ServerImpl.doStart(ServerImpl.java:335)
      at org.jboss.system.server.ServerImpl.start(ServerImpl.java:291)
      at org.jboss.Main.boot(Main.java:150)
      at org.jboss.Main$1.run(Main.java:395)
      at java.lang.Thread.run(Thread.java:595)
      Press any key to continue . . .

      What could be wrong?
      Thanks,
      Guru