0 Replies Latest reply on Mar 4, 2005 3:54 PM by s g

    localhost bind?

    s g Newbie

      When I start jboss' tomcat container, it binds to port 8080 on localhost. I can't access it from any other machine. As this is a headless server, which has a webapplication that's supposed to be publicly accessible, this won't work very well for my purpose. The startup log is below:
      12:34:59,825 INFO [Server] Starting JBoss (MX MicroKernel)...
      12:34:59,829 INFO [Server] Release ID: JBoss [Zion] 4.0.1sp1 (build: CVSTag=JBoss_4_0_1_SP1 date=200502160314)
      12:34:59,834 INFO [Server] Home Dir: /usr/local/jboss-4.0.1sp1
      12:34:59,835 INFO [Server] Home URL: file:/usr/local/jboss-4.0.1sp1/
      12:34:59,835 INFO [Server] Library URL: file:/usr/local/jboss-4.0.1sp1/lib/
      12:34:59,838 INFO [Server] Patch URL: null
      12:34:59,854 INFO [Server] Server Name: default
      12:34:59,855 INFO [Server] Server Home Dir: /usr/local/jboss-4.0.1sp1/server/default
      12:34:59,855 INFO [Server] Server Home URL: file:/usr/local/jboss-4.0.1sp1/server/default/
      12:34:59,856 INFO [Server] Server Data Dir: /usr/local/jboss-4.0.1sp1/server/default/data
      12:34:59,856 INFO [Server] Server Temp Dir: /usr/local/jboss-4.0.1sp1/server/default/tmp
      12:34:59,856 INFO [Server] Server Config URL: file:/usr/local/jboss-4.0.1sp1/server/default/conf/
      12:34:59,857 INFO [Server] Server Library URL: file:/usr/local/jboss-4.0.1sp1/server/default/lib/
      12:34:59,858 INFO [Server] Root Deployment Filename: jboss-service.xml
      12:34:59,868 INFO [Server] Starting General Purpose Architecture (GPA)...
      12:35:01,202 INFO [ServerInfo] Java version: 1.4.2_05,Apple Computer, Inc.
      12:35:01,203 INFO [ServerInfo] Java VM: Java HotSpot(TM) Client VM 1.4.2-38,"Apple Computer, Inc."
      12:35:01,203 INFO [ServerInfo] OS-System: Mac OS X 10.3.8,ppc
      12:35:02,221 INFO [Server] Core system initialized
      12:35:07,805 INFO [Log4jService$URLWatchTimerTask] Configuring from URL: resource:log4j.xml
      12:35:08,175 INFO [WebService] Using RMI server codebase: http://Hasan-Diwans-Computer.local:8083/
      12:35:08,920 INFO [NamingService] Started jndi bootstrap jnpPort=1099, rmiPort=1098, backlog=50, bindAddress=/0.0.0.0, Client SocketFactory=null, Server SocketFactory=org.jboss.net.sockets.DefaultSocketFactory@ad093076
      12:35:21,255 INFO [Embedded] Catalina naming disabled
      12:35:23,240 INFO [Http11Protocol] Initializing Coyote HTTP/1.1 on http-0.0.0.0-8080
      12:35:23,352 INFO [Catalina] Initialization processed in 1446 ms
      12:35:23,354 INFO [StandardService] Starting service jboss.web
      12:35:23,364 INFO [StandardEngine] Starting Servlet Engine: Apache Tomcat/5.0.28
      12:35:23,412 INFO [StandardHost] XML validation disabled
      12:35:23,457 INFO [Catalina] Server startup in 104 ms
      12:35:23,831 INFO [TomcatDeployer] deploy, ctxPath=/invoker, warUrl=file:/usr/local/jboss-4.0.1sp1/server/default/deploy/http-invoker.sar/invoker.war/
      12:35:26,076 INFO [TomcatDeployer] deploy, ctxPath=/ws4ee, warUrl=file:/usr/local/jboss-4.0.1sp1/server/default/tmp/deploy/tmp28348jboss-ws4ee.war/
      12:35:26,650 INFO [TomcatDeployer] deploy, ctxPath=/, warUrl=file:/usr/local/jboss-4.0.1sp1/server/default/deploy/jbossweb-tomcat50.sar/ROOT.war/
      12:35:27,295 INFO [TomcatDeployer] deploy, ctxPath=/jbossmq-httpil, warUrl=file:/usr/local/jboss-4.0.1sp1/server/default/deploy/jms/jbossmq-httpil.sar/jbossmq-httpil.war/
      12:35:33,465 INFO [MailService] Mail Service bound to java:/Mail
      12:35:36,009 INFO [RARDeployment] Required license terms exist view the META-INF/ra.xml: file:/usr/local/jboss-4.0.1sp1/server/default/deploy/jboss-local-jdbc.rar
      12:35:36,426 INFO [RARDeployment] Required license terms exist view the META-INF/ra.xml: file:/usr/local/jboss-4.0.1sp1/server/default/deploy/jboss-xa-jdbc.rar
      12:35:36,759 INFO [RARDeployment] Required license terms exist view the META-INF/ra.xml: file:/usr/local/jboss-4.0.1sp1/server/default/deploy/jms/jms-ra.rar
      12:35:36,993 INFO [RARDeployment] Required license terms exist view the META-INF/ra.xml: file:/usr/local/jboss-4.0.1sp1/server/default/deploy/mail-ra.rar
      12:35:39,381 INFO [WrapperDataSourceService] Bound connection factory for resource adapter for ConnectionManager 'jboss.jca:name=DefaultDS,service=DataSourceBinding to JNDI name 'java:DefaultDS'
      12:35:39,492 WARN [ConfiguredIdentityLoginModule] Creating LoginModule with no configured password!
      12:35:40,258 INFO [A] Bound to JNDI name: queue/A
      12:35:40,266 INFO [B] Bound to JNDI name: queue/B
      12:35:40,271 INFO [C] Bound to JNDI name: queue/C
      12:35:40,278 INFO [D] Bound to JNDI name: queue/D
      12:35:40,286 INFO [ex] Bound to JNDI name: queue/ex
      12:35:40,355 INFO [testTopic] Bound to JNDI name: topic/testTopic
      12:35:40,361 INFO [securedTopic] Bound to JNDI name: topic/securedTopic
      12:35:40,368 INFO [testDurableTopic] Bound to JNDI name: topic/testDurableTopic
      12:35:40,373 INFO [testQueue] Bound to JNDI name: queue/testQueue
      12:35:40,534 INFO [UILServerILService] JBossMQ UIL service available at : /0.0.0.0:8093
      12:35:40,645 INFO [DLQ] Bound to JNDI name: queue/DLQ
      12:35:41,198 INFO [ConnectionFactoryBindingService] Bound connection factory for resource adapter for ConnectionManager 'jboss.jca:name=JmsXA,service=ConnectionFactoryBinding to JNDI name 'java:JmsXA'
      12:35:41,860 INFO [TomcatDeployer] deploy, ctxPath=/GMailRSS, warUrl=file:/usr/local/jboss-4.0.1sp1/server/default/tmp/deploy/tmp28399GMailRSS.war/
      12:35:42,561 INFO [TomcatDeployer] deploy, ctxPath=/jmx-console, warUrl=file:/usr/local/jboss-4.0.1sp1/server/default/deploy/jmx-console.war/
      12:35:42,911 INFO [TomcatDeployer] deploy, ctxPath=/web-console, warUrl=file:/usr/local/jboss-4.0.1sp1/server/default/deploy/management/web-console.war/
      12:35:44,760 INFO [Http11Protocol] Starting Coyote HTTP/1.1 on http-0.0.0.0-8080
      12:35:45,085 INFO [ChannelSocket] JK2: ajp13 listening on /0.0.0.0:8009
      12:35:45,096 INFO [JkMain] Jk running ID=0 time=1/135 config=null
      12:35:45,115 INFO [Server] JBoss (MX MicroKernel) [4.0.1sp1 (build: CVSTag=JBoss_4_0_1_SP1 date=200502160314)] Started in 44s:716ms

      The boldfaced line is key. What I've tried so far:
      My nameserver lists Hasan-Diwans-Computer.local as 127.0.0.1; I changed that to 192.168.0.153 (the server's external IP address) to no go.
      To verify existence of the problem:
      [on localhost]
      Hasan-Diwans-Computer: 12:41pm %nc -vvv -w 5 localhost 8080 [~]
      localhost [127.0.0.1] 8080 (http-alt) open
      get / http/1.1

      HTTP/1.1 505 HTTP Version Not Supported
      Date: Fri, 04 Mar 2005 20:41:57 GMT
      Server: Apache-Coyote/1.1
      Connection: close

      [on a remote host on the same subnet]
      Hasans-iBook: 12:42pm %nc -vvv -w 5 192.168.0.153 8080 [~]
      hasan.wits2020.net [192.168.0.153] 8080 (http-alt) : Operation timed out
      sent 0, rcvd 0

      Note, this has nothing to do with any code I've written; it's the stock JBoss 3.2.6 which Apple provides on the Panther CDROM. I also tried to manually install a version of JBoss 4 and it exhibited the same error.
      I took note of the "jboss.bind.address" property in $JBOSS_HOME/server/default/jbossweb-tomcat50.sar/server.xml, I tried to set it to 192.168.0.153 and still got the results as above.
      As a last chance, I located the "Engine" tag in the same file and tried to change its "host" attribute to "server" (the server's DNS name), "server.hasan.wits2020.net" (server's FQDN), and "192.168.0.153" (the server's IP -- verified using ifconfig). Here, it gives unknown host.
      At this point, I have exhausted all the possibilities I can think of, so I turn it over to you -- the wise people of the JBoss forum -- for assistance. Thanks in advance!