3 Replies Latest reply on May 20, 2005 10:59 AM by Kai Baufeldt

    [b]JasperException: Unable to compile class for JSP[/b] afte

    Mathias Peters Newbie

      Hi to everybody,

      I am upgrading my webapp to Java 1.5 and myfaces 1.0.9.
      Compiling woks fine and I only needed to rearange some import of myfaces(from net.sourceforge... to org.apache...).
      But when I deploying the app and accessing the first jsp, I get errors like

      org.apache.jasper.JasperException: Unable to compile class for JSP
      
      Generated servlet error:
      error: error reading C:\Programme\jboss-3.2.5\server\default\deploy\comitatus-webapp.war\WEB-INF\lib\struts-config_1_1.dtd; java.util.zip.ZipException: error in opening zip file
      
      
      Generated servlet error:
      Note: C:\Programme\jboss-3.2.5\server\default\work\jboss.web\localhost\comitatus-webapp\org\apache\jsp\index_jsp.java uses unchecked or unsafe operations.
      
      
      Generated servlet error:
      Note: Recompile with -Xlint:unchecked for details.
      1 error
      


      I encountered some posts in the jboss forum, that described similar errors, but none of the solutions worked for me.
      Does anybody know wether this is a jboss issue and how to fix it?
      thank you in advance
      matze