1 Reply Latest reply on May 20, 2005 1:50 AM by Raja

    java.lang.IllegalArgumentException: No bean specified

    Jambu Nath Newbie

      Hello,
      Can any one help me to resolve this problem?
      I am getting the following exception when I try to submit a page. I am using Struts and Jboss as application server

      java.lang.IllegalArgumentException: No bean specified

      java.lang.IllegalArgumentException: No bean specified
      at org.apache.commons.beanutils.PropertyUtils.getPropertyDescriptor(Prop
      ertyUtils.java:837)
      at org.apache.commons.beanutils.BeanUtils.setProperty(BeanUtils.java:934
      )
      at org.apache.commons.beanutils.BeanUtils.populate(BeanUtils.java:808)
      at org.apache.struts.util.RequestUtils.populate(RequestUtils.java:978)
      at org.apache.struts.action.RequestProcessor.processPopulate(RequestProc
      essor.java:779)
      at org.apache.struts.action.RequestProcessor.process(RequestProcessor.ja
      va:246)
      at org.apache.struts.action.ActionServlet.process(ActionServlet.java:129
      2)
      at org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:510)

      at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)


      When I load the page first time it is coming out properly. I am entering few information and then submitting the page. When I do so I am getting the above exception.
      I have proper name tag for this action in the struts-config. xml file.

      Thanks in advance,
      Jambu