0 Replies Latest reply on Jun 25, 2005 4:18 PM by Robert Slaght

    JBOSS EJB3 Problem

    Robert Slaght Newbie

      I installed all the EJB3 stuff for JBoss and the first time I used annotations and entities to put java class data in the database it worked just fine. But as I added functionality to my stateless bean the new functionality doesn't seem to be working. Heres my example code


      InitialContext ctx = new InitialContext();

      GeckoModelRemote gecko = (GeckoModelRemote) ctx.lookup(GeckoModelRemote.class.getName());

      boolean worked = gecko.createAccount(firstName, lastName, email, password, securityQuestion, answer);

      It seems to me that my lookup is getting the class that I first used and not the new one that I added functionality to. I say that because even when I take out all the classes that are using EJB3 annotations
      (removed completely from the JBoss all/deploy directory) I get this message when JBoss loads up

      13:04:16,311 INFO [Ejb3Module] found EJB3 Entity bean: model.Account
      13:04:16,331 INFO [Ejb3Module] found EJB3 stateless session bean: model.GeckoModelBean
      13:04:16,394 INFO [Ejb3Module] found EJB3 Entity bean: model.Password


      If this is not enough information let me know and I will put it in my next post. Any help would be greatly appreciated.