1 Reply Latest reply on Oct 5, 2005 10:36 AM by Filippo

    The infamous RmiModeler: ClassNotFoundException

    Steve Hanson Newbie

      I've been searching and reading about this error for two days. Nothing I've read has helped me, and I've tried everything.

      Here is my config.xml:

      <?xml version="1.0" encoding="UTF-8"?>
      <configuration xmlns="http://java.sun.com/xml/ns/jax-rpc/ri/config">
       <service name="FrontController"
       targetNamespace="urn:ws.web/wsdl"
       typeNamespace="urn:ws.web/types"
       packageName="ws.web">
       <interface name="ws.web.FrontControllerInterface" servantName="ws.web.FrontControllerServlet"/>
       </service>
      </configuration>
      


      Here is my directory structure:
      - WS_Example (project root)
      config.xml
      -- bin
      --- ws
      ---- web
      FrontControllerServlet.class
      FrontControllerInterface.class
      -- src
      --- ws
      ---- web
      FrontControllerServlet.java
      FrontControllerInterface.java

      I am running this command from the WS_Example root folder:
      wscompile -cp "ws.web.FrontControllerServlet" -gen:server -f:rpcliteral -mapping jaxrpc-mapping.xml config.xml
      


      This is my error message:

      error: RmiModeler error: java.lang.ClassNotFoundException: ws$web$FrontControllerInterface


      I've tried flattening the package name, running wscompile from different folders, and lots of other stuff too. I am desperate for any suggestions and this error has put me two days behind schedule. Please help....

        • 1. Re: The infamous RmiModeler: ClassNotFoundException
          Filippo Newbie

          Hey, I'm here...
          I'm just telling you what worked for me.

          From within the project root dir I execute the following command:

          wscompile -verbose -classpath ./bin -gen:server -f:rpcliteral -mapping mapping.xml config.xml

          where config.xml is in the project root dir;
          where bin is the dir where Eclipse put the compiled classes and related packages (bin is a child of project root dir).

          I think you are wrong in the dir name format.

          Hope this works.