1 Reply Latest reply on Oct 7, 2005 3:37 AM by Fabian Burtard

    Linkage error: migrating from 4.0.2 to 4.0.3

    Fabian Burtard Newbie

      Hi,

      I'm interesting to use the jboss4.0.3 because of the new bugfix.
      So i download the zip archive, extract on my server and launch jboss with jdk1.4.

      The same ear archive works on jboss4.0.2 but not on jboss4.0.3.
      On jboss4.0.2, i just remove the UseJbossClassLoader attribute on the jboss-service.xml but this attribute is not on the 4.0.3 version

      I have the following error when i execute a method on a session bean:

      javax.servlet.ServletException: Servlet execution threw an exception
      org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:81)
      
      root cause
      
      java.lang.LinkageError: loader constraints violated when linking



      Could anyone can explain me what can i do to run my application ? or what i'm doing wrong in my configuration that work in 4.0.2 but not in 4.0.3 ?


      Thanks