0 Replies Latest reply on Nov 14, 2005 4:47 PM by John Doe

    JBMS and Hibernate

    John Doe Newbie

      Whenever I try to start the JBoss server with the JBoss Mail Server installed, I get the following error:

      --- MBeans waiting for other MBeans ---
      ObjectName: jboss.mail:service=Hibernate
      State: CONFIGURED
      I Depend On:
      jboss.har:service=HARDeployer
      jboss.jca:service=LocalTxCM,name=JBMSDS

      --- MBEANS THAT ARE THE ROOT CAUSE OF THE PROBLEM ---
      ObjectName: jboss.har:service=HARDeployer
      State: NOTYETINSTALLED
      Depends On Me:
      jboss.mail:service=Hibernate


      My hibernate-service.xml for the JBMS app looks like:

      <?xml version="1.0" encoding="UTF-8"?>
      <!--
      <!DOCTYPE jboss PUBLIC "-//JBoss//DTD JBOSS 4.0//EN"
       "http://www.jboss.org/j2ee/dtd/jboss-service_4_0.dtd">
      -->
      <jboss>
       <mbean code="org.jboss.hibernate.jmx.Hibernate"
       name="jboss.mail:service=Hibernate">
      
       <depends>jboss.har:service=HARDeployer</depends>
       <depends>jboss.jca:service=LocalTxCM,name=JBMSDS</depends>
      
       <attribute name="DatasourceName">java:/JBMSDS</attribute>
       <attribute name="SessionFactoryName">java:/jbossmail.HibernateSessionFactory</attribute>
       <attribute name="Dialect">org.hibernate.dialect.PostgreSQLDialect</attribute>
       <attribute name="Hbm2ddlAuto">update</attribute>
       <attribute name="ShowSqlEnabled">false</attribute>
      
       <!--attribute name="CacheProviderClass">
       net.sf.hibernate.cache.TreeCacheProvider
       </attribute-->
       <attribute name="CacheProviderClass">org.hibernate.cache.HashtableCacheProvider</attribute>
       </mbean>
      </jboss>


      And the jboss-service.xml in the META-INF folder under the mail.ear app has the PostgreSQL part that was mentioned in the instructions:

      <!--
       PostgreSQL base store that uses the LargeObjectAPI
       in order to store data.
       -->
       <mbean code="org.jboss.mail.store.postgresql.PostgreSQLStore"
       name="jboss.mail:type=MailServices,name=PostgreSQLStore">
       <attribute name="Disconnected">true</attribute>
       <attribute name="DataSource">java:/JBMSDS</attribute>
       <attribute name="PageSize">131072</attribute>
       </mbean>
      
      
       <!-- Mail Body Manager -->
       <mbean code="org.jboss.mail.message.MailBodyManager"
       name="jboss.mail:type=MailServices,name=MailBodyManager">
       <attribute name="UseStore">true</attribute>
       <depends optional-attribute-name="Store"
       proxy-type="attribute">jboss.mail:type=MailServices,name=PostgreSQLStore</depends>
       </mbean>
      


      I know its probably something stupid I'm missing. And yes, I started the Database server.