2 Replies Latest reply on Nov 15, 2005 3:59 PM by Jason Oh

    multiple installation/startup issues

    Jason Oh Newbie

      hello all,
      i'm trying to install and startup the full jboss-4.0.3 installation on suse 9.0 but am running into numerous issues in my attempts to do so. i've scoured the forums, but have only found slight intersections with my issues. i will address each seemingly distinct issue in order of occurrence.

      the first issue (the lovely ClassNotFoundException) arises immediately after the "Core system initialized" message:

      09:18:03,551 ERROR [MainDeployer] Could not create deployment: file:/home/indexprod/jboss-4.0.3/server/default/deploy/ejb3.de\
      ployer/
      org.jboss.deployment.DeploymentException: Unexpected error during load of: org.jboss.ejb3.EJB3Deployer, msg=org/jboss/ejb3/EJ\
      B3Deployer (Unsupported major.minor version 49.0); - nested throwable: (java.lang.ClassNotFoundException: Unexpected error du\
      ring load of: org.jboss.ejb3.EJB3Deployer, msg=org/jboss/ejb3/EJB3Deployer (Unsupported major.minor version 49.0))
       at org.jboss.system.ServiceConfigurator.install(ServiceConfigurator.java:178)
       at org.jboss.system.ServiceController.install(ServiceController.java:215)
       at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
       at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
       at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
       at java.lang.reflect.Method.invoke(Method.java:324)
      [...]
      

      based on the documentation, i'm unaware of any external dependencies for ejb 3.0, nor of any external files that are required for this to work.

      so, following that exception, we get another exception, this time the NoClassDefFoundError:
      09:18:04,748 WARN [ServiceController] Problem creating service jboss.aop:service=AspectManager
      java.lang.NoClassDefFoundError: org/jboss/aop/advice/Scope
       at org.jboss.aop.advice.ScopeUtil.parse(ScopeUtil.java:19)
       at org.jboss.aop.AspectXmlLoader.deployInterceptor(AspectXmlLoader.java:145)
       at org.jboss.aop.AspectXmlLoader.loadInterceptors(AspectXmlLoader.java:310)
       at org.jboss.aop.AspectXmlLoader.deployInterceptorStack(AspectXmlLoader.java:454)
       at org.jboss.aop.AspectXmlLoader.deployTopElements(AspectXmlLoader.java:962)
       at org.jboss.aop.AspectXmlLoader.deployXML(AspectXmlLoader.java:826)
       at org.jboss.aop.AspectXmlLoader.deploy(AspectXmlLoader.java:1139)
       at org.jboss.aop.AspectXmlLoader.deployXML(AspectXmlLoader.java:1159)
       at org.jboss.aop.deployment.AspectManagerService.baseAop(AspectManagerService.java:122)
      

      i get a couple of these stack traces.

      next, i get an error indicating the the port 8083 is already in use (i'll refrain from posting the stack trace as we all know what that one looks like). fine, but how do i configure jboss to point someplace else then as that port is indeed in use and cannot be modified?

      next, another exception:
      09:18:12,369 ERROR [MainDeployer] Could not create deployment: file:/home/indexprod/jboss-4.0.3/server/default/deploy/ejb3-cl\
      ustered-sfsbcache-service.xml
      org.jboss.deployment.DeploymentException: No ClassLoaders found for: org.jboss.ejb3.cache.tree.PassivationTreeCache; - nested\
       throwable: (java.lang.ClassNotFoundException: No ClassLoaders found for: org.jboss.ejb3.cache.tree.PassivationTreeCache)
       at org.jboss.system.ServiceConfigurator.install(ServiceConfigurator.java:178)
       at org.jboss.system.ServiceController.install(ServiceController.java:215)
       at sun.reflect.GeneratedMethodAccessor9.invoke(Unknown Source)
       at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
       at java.lang.reflect.Method.invoke(Method.java:324)
       at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:141)
       at org.jboss.mx.server.Invocation.dispatch(Invocation.java:80)
       at org.jboss.mx.server.Invocation.invoke(Invocation.java:72)
       at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:245)
       at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:644)
       at org.jboss.mx.util.MBeanProxyExt.invoke(MBeanProxyExt.java:176)
      

      i have no idea what that means or how to begin resolving this issue.

      next, i get a warning exception, indicating that my port 1098 is already in use (it's not, either before nor after i start jboss, according to netstat: see article http://www.jboss.com/index.html?module=bb&op=viewtopic&t=67937).
      this seems to be some sort of bug, but apparently not for most people... i've followed the workaround instructions in the indicated article, but to no avail.

      after all that i get the "--- Packages waiting for a deployer ---" section, but i'll only post that if it will help as it's quite lengthy.

      i was hoping to get this running out of the box, but it appears it's not ready for that sort of setup.

      any and all help would be greatly appreciated.

      thanks,
      jason

        • 1. Re: multiple installation/startup issues
          Darran Lofthouse Master

          What is the JDK version that you are using?

          Based on the error you have posted it looks like you are using a JDK before Java 5, Java 5 is required for EJB 3.

          http://www.jboss.com/products/ejb3

          When trying to resolve JBoss issues it is better to just focus on the first problem instead of trying to look at all of the problems at once as some of them may be caused / affected by the first problem.

          • 2. Re: multiple installation/startup issues
            Jason Oh Newbie

            ok, so the jdk 1.4.1 i was using did cause a number of those issues it looks like. i've upgraded to 1.5.0_05 and now it looks a little better, but i'm still getting some exceptions.

            the first exception deals with the port 8083 address being already used. it appears that it doesn't attempt to change ports in the event of this exception--how does one go about changing the server port setting?

            soon thereafter, i get a warning message: "15:48:16,345 WARN [TreeCache] No transaction manager lookup class has been defined. Transactions cannot be used." is this something that must be setup explicitly by me or is this a sign of a deeper problem?

            i get another port already in use exception for the rmi portion i believe, as it complains about port 1098. however, as indicated in my original post, the port is definitely -not- in use before nor after i execute run.sh. how is this to be resolved?

            that does it for the exceptions, but this is clearly a crippled startup and not usable.

            thanks for your input.

            cheers,
            jason