0 Replies Latest reply on Nov 19, 2005 4:19 PM by Ken Rubensteinerwitz

    Can't start first JSP, but not sure why when looking at logs

    Ken Rubensteinerwitz Newbie

      Hello.

      I tried to deploy the quote JSP for JBoss A developer's notebook.
      Received the following error:

      When starting web application at http://localhost:8080/quote/quote, I get message:

      HTTP Status 404 - /quote/quote

      type Status report

      message /quote/quote.

      description The requested resource (/quote/quote) is not available.
      Apache Tomcat/5.0.28

      Console Window

      at java.lang.Thread.run(Thread.java:534)
      14:38:50,334 INFO [TomcatDeployer] undeploy, ctxPath=/, warUrl=file:/C:/jboss-4
      .0.1sp1/server/default/tmp/deploy/tmp56952quote-exp.war/
      14:38:50,735 INFO [TomcatDeployer] deploy, ctxPath=/, warUrl=file:/C:/jboss-4.0
      .1sp1/server/default/tmp/deploy/tmp56953quote-exp.war/

      Server Log

      2005-11-19 14:38:52,738 DEBUG [tomcat.localhost.ROOT.Context] Starting completed
      2005-11-19 14:38:52,738 DEBUG [tomcat.localhost.ROOT.Context] Checking for jboss.web:J2EEApplication=none,J2EEServer=none,j2eeType=WebModule,name=//localhost/
      2005-11-19 14:38:52,758 DEBUG [org.jboss.web.tomcat.tc5.TomcatDeployer] Initialized: {WebApplication: /C:/jboss-4.0.1sp1/server/default/tmp/deploy/tmp56953quote-exp.war/, URL: file:/C:/jboss-4.0.1sp1/server/default/tmp/deploy/tmp56953quote-exp.war/, classLoader: java.net.FactoryURLClassLoader@805298:8409752} jboss.web:J2EEApplication=none,J2EEServer=none,j2eeType=WebModule,name=//localhost/
      2005-11-19 14:38:52,758 DEBUG [org.jboss.web.WebModule] Started jboss.web.deployment:id=-462022578,war=quote.war
      2005-11-19 14:38:52,758 DEBUG [org.jboss.system.ServiceController] Starting dependent components for: jboss.web.deployment:id=-462022578,war=quote.war dependent components: []
      2005-11-19 14:38:52,818 DEBUG [org.jboss.deployment.MainDeployer] End deployment start on package: quote.war
      2005-11-19 14:38:52,818 DEBUG [org.jboss.deployment.MainDeployer] Deployed package: file:/C:/jboss-4.0.1sp1/server/default/deploy/quote.war

      War is quote.war
      web.xml is below
      <?xml version="1.0" ?>
      <web-app xmlns="http://java.sun.com/xml/ns/j2ee"
      xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee http://java.sun.com/xml/ns/j2ee/web-app_2_4.xsd"
      version="2.4">

      <servlet-name>QuoteServlet</servlet-name>
      <jsp-file>/quote.jsp</jsp-file>

      <servlet-mapping>
      <servlet-name>QuoteServlet</servlet-name>
      <url-pattern>/quote</url-pattern>
      </servlet-mapping>
      </web-app>

      Any clues would be greatly appreciated. It is interesting that the ctxpath =/.
      Is this the trouble.

      Thank you,

      Ken