1 Reply Latest reply on Jan 6, 2006 12:28 PM by Arnie Morein

    HAR problem: Incomplete Deployment listing: Packages waiting

    Arnie Morein Novice

      Am trying to deploy a EAR with a WAR and HAR and getting the following:

      10:16:05,562 INFO [EARDeployer] Started J2EE application: file:/C:/Dev/jboss401sp1/server/default/d
      eploy/txoag.ear
      10:16:05,562 ERROR [URLDeploymentScanner] Incomplete Deployment listing:
      Packages waiting for a deployer:
      org.jboss.deployment.DeploymentInfo@eef7b847 { url=file:/C:/Dev/jboss401sp1/server/default/tmp/deplo
      y/tmp14151txoag.ear-contents/txoagPortal.har }
      deployer: null
      status: Starting
      state: START_SUBDEPLOYMENTS
      watch: file:/C:/Dev/jboss401sp1/server/default/tmp/deploy/tmp14151txoag.ear-contents/txoagPortal.h
      ar
      altDD: null
      lastDeployed: 1136564105609
      lastModified: 1136564104750
      mbeans:

      My structures are:

      -- txoag.ear
      |-- txoagPortal.har
      |--/meta-inf/jboss-service.xml (see below)
      |--/<project name>/<class files>
      |--/<project name>/<hbm.xml files>
      |
      |-- txoagPortal.war
      |
      |-- /meta-inf/application.xml
      |
      |-- /meta-inf/jboss-app.xml (see below)

      The hbm.xml files are in the same folders as their related class files.

      BEGIN - jboss-app.xml - BEGIN
      <?xml version='1.0' encoding='UTF-8' ?>

      <!DOCTYPE jboss-app PUBLIC "-//JBoss//DTD J2EE Application 1.4//EN" "http://www.jboss.org/j2ee/dtd/jboss-app_4_0.dtd">
      <jboss-app>
      <loader-repository>com.novell:loader=unique.ear.name
      <loader-repository-config>java2ParentDelegation=true</loader-repository-config>
      </loader-repository>

      txoagPortal.har

      </jboss-app>
      END - jboss-app.xml - END

      BEGIN - jboss-service.xml - BEGIN
      <?xml version="1.0" encoding="UTF-8"?>


      java:/appsec
      net.sf.hibernate.dialect.SybaseDialect
      java:/hibernate/txoagPortalSessionFactory -->
      net.sf.hibernate.cache.HashtableCacheProvider
      update
      true


      END - jboss-service.xml - END

        • 1. Re: HAR problem: Incomplete Deployment listing: Packages wai
          Arnie Morein Novice

          renamed the jboss-service.xml to hibernate-service.xml and things seem to be going now, but:

          2006-01-06 11:15:07,859 INFO [net.sf.hibernate.cfg.Environment] Hibernate 2.1.6
          2006-01-06 11:15:07,875 INFO [net.sf.hibernate.cfg.Environment] hibernate.properties not found
          2006-01-06 11:15:07,875 INFO [net.sf.hibernate.cfg.Environment] using CGLIB reflection optimizer
          2006-01-06 11:15:07,890 INFO [net.sf.hibernate.cfg.Configuration] Searching for mapping documents in jar: txoagPortal.har
          2006-01-06 11:15:07,906 INFO [net.sf.hibernate.cfg.Configuration] Found mapping documents in jar: AppSecMgmt/Info_User.hbm.xml
          2006-01-06 11:15:09,015 ERROR [net.sf.hibernate.cfg.Configuration] Could not configure datastore from input stream
          org.dom4j.DocumentException: Connection refused: connect Nested exception: Connection refused: connect
          at org.dom4j.io.SAXReader.read(SAXReader.java:353)

          Here is the contents of the lone hbm file:

          <?xml version="1.0" encoding="UTF-8"?>
          <!DOCTYPE hibernate-mapping PUBLIC "-//Hibernate/Hibernate Mapping DTD 3.0//EN"
          "http://hiberate.sourceforge.net/hibernate-mapping-3.0.dtd">

          <hibernate-mapping package="us.tx.state.oag.AppSecMgmt.hiberate"
          schema="application_security"/>


          <id name="userID" type="big_integer" column="user_id"
          unsaved-value="null" generator-class="native"/>



















          </hibernate-mapping>