1 Reply Latest reply on Jan 9, 2006 8:55 PM by Robert White

    Source not found message

    Robert White Newbie

      I am trying to follow the JBoss Eclipse IDE Trailblazer with considerable help from jbosszone at http://www.jboss.com/index.html?module=bb&op=viewtopic&t=72043

      However when I try to deploy author.war and authors-beans.ejb3 I get
      1.) a request to go into the debug perspective and
      2.) an Author.getAuthorID tab saying "source not found" with a button "edit source".
      3.) a debug tab that refers to Author.getAuthorID() line: 35 but if I use Eclipse's go to line number it takes me to the return statement.

      @Id(generate = GeneratorType.AUTO)
       @Column(name="authorId")
       public int getAuthorId() {
       return authorId;
       }

      Some thing has clearly gone wrong but I cannot see what!!!

      Using WinZip I have taken a look at the deployed files
      1.) author.war
       WEB-INF\classes\org\jboss3demo\web\AuthorServlet.class
       meta-inf\Manifest.mf
       we-inf\web.xml
      2.) authors-beans.ejb3
       org\jboss\ejb3demo\Article.class
       org\jboss\ejb3demo\Author.class
       org\jboss\ejb3demo\Authors.class
       org\jboss\ejb3demo\AuthorsBean.class
       meta-ing\Manifest.mf
       jndi.properties
       web.xml

      OK I can see two web.xml files which I know is wrong but doesn't seem to be a problem.

      I began studying JBoss, Eclipse and MySql yesterday so it is probably a stupid mistake. But any help would be appreciated.

        • 1. Re: Source not found message
          Robert White Newbie

          OK I've got it working.

          1.) The "Source not found" message is not an error. Eclipse is running the deployed files but has had a problem. By pointing to where the source files are it can highlight the problem lines.

          2.) This then allowed me to step into the JBoss classes where I had problems. This was resolved by re-installing JBoss AS. The initial installation was "EJB 3" with "default configuration. The reinstallation was "EJB 3" with "all configuration."

          After that everything worked.

          3.) Thanks to JBossZone again. However the recommendation to install a classpath environmental value didn't seem necessary. Infact when I tried this the following problem occurred.

          Java Build Path
           Libraries
           JBoss EJB3 Libraries[error]
           Access rules: No rules defined


          and none of the EJB 3 annotations was then recognised.

          However everything is now working. EJB 3 is looking better than EJB 2. Life is great. I'm going on a celebratory walk round the block.