4 Replies Latest reply on Jun 14, 2006 2:46 PM by Drew Cox

    DeploymentException: No META-INF/application.xml found

    Bjørn Børresen Newbie

      Hi guys .. I get a message saying that no application.xml is found, even though I know it is there.

      Here's the exception:

      11:17:31,921 ERROR [MainDeployer] Could not initialise deployment: file:/C:/Prog
      ramfiler/jboss-4.0.4.CR2/server/default/deploy/cmdtest.ear
      org.jboss.deployment.DeploymentException: No META-INF/application.xml found
       at org.jboss.deployment.EARDeployer.init(EARDeployer.java:133)
       at org.jboss.deployment.MainDeployer.init(MainDeployer.java:861)
       at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:798)
       at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:771)
       at sun.reflect.GeneratedMethodAccessor8.invoke(Unknown Source)
       at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
      sorImpl.java:25)
       at java.lang.reflect.Method.invoke(Method.java:585)
       at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatch
      er.java:155)
       at org.jboss.mx.server.Invocation.dispatch(Invocation.java:94)
       at org.jboss.mx.interceptor.AbstractInterceptor.invoke(AbstractIntercept
      or.java:133)
       at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
       at org.jboss.mx.interceptor.ModelMBeanOperationInterceptor.invoke(ModelM
      BeanOperationInterceptor.java:142)
       at org.jboss.mx.server.Invocation.invoke(Invocation.java:88)
       at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.
      java:260)
       at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:659)
       at org.jboss.mx.util.MBeanProxyExt.invoke(MBeanProxyExt.java:190)
       at $Proxy6.deploy(Unknown Source)
       at org.jboss.deployment.scanner.URLDeploymentScanner.deploy(URLDeploymen
      tScanner.java:334)
       at org.jboss.deployment.scanner.URLDeploymentScanner.scan(URLDeploymentS
      canner.java:522)
       at org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread.
      doScan(AbstractDeploymentScanner.java:207)
       at org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread.
      loop(AbstractDeploymentScanner.java:218)
       at org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread.
      run(AbstractDeploymentScanner.java:197)
      


      Here's the contents of cmdtest.ear:
      bash-2.05a$ unzip -l cmdtest.ear
      Archive: cmdtest.ear
       Length Date Time Name
       -------- ---- ---- ----
       0 05-05-06 15:09 META-INF/
       106 05-05-06 15:09 META-INF/MANIFEST.MF
       338 05-05-06 11:22 META-INF/application.xml
       7753 05-05-06 15:09 cmdtest-ejb.jar
       350 05-05-06 11:15 cmdtest.war
       -------- -------
       8547 5 files
      


      I also checked jboss-home/server/default/tmp/deploy and I found that it gets application.xml ..

      So, isn't this very strange?

      - bjornbjorn

        • 1. Re: DeploymentException: No META-INF/application.xml found
          jaikiran pai Master

          How did you create your jar/ear?

          Use the following commands to create the jar, ear or war:

          jar -cvf myApp.war *.*


          jar -cvf myApp.ear *.*




          jar -cvf myApp.jar *.*





          • 2. Re: DeploymentException: No META-INF/application.xml found
            Bjørn Børresen Newbie

            I use ant to do that, here's an example of my .war creation:

            <target name="war">
             <jar jarfile="${app.war}">
             <fileset dir="${source.dir}">
             <include name="WEB-INF/web.xml"/>
             <include name="*.jsp"/>
             </fileset>
             </jar>
             </target>
            


            I'm pretty sure that this is not the problem as I've just modified a working build for my use.

            - bjorn

            • 3. Re: DeploymentException: No META-INF/application.xml found
              Drew Cox Newbie

              I too have just started experiencing this problem in development on a working build, after several months of successful deployment on 4.0.3sp1.

              I have googled a lot on this and seen little bits of info (like make sure there isn't an empty 'classpath:" setting in our EAR MANIFEST.MF), but nothing that fits my situation.

              The only lead I am working on at the moment is that I switched from the Ant task to the task around the time this started breaking...but not exactly, I would swear that change was fine. And I tried switching back to the jar task to no avail.

              Please, if anyone has come across this issue, any advice would be be appreciated

              • 4. Re: DeploymentException: No META-INF/application.xml found
                Drew Cox Newbie

                Ok, well, it looks like I have found my problem, which I expect to be unique.

                I was receiving this error message because I had a config file in my application's classpath called app.properties.ear. This was actually in an ejb-jar.jar file in the application ear file.

                JBoss seemed to get quite confused about that and thought it was a real ear file itself and could not find the META-INF/application.xml in it (of course, cause it was a simple text properties file.)

                Pity the error messages were note a bit more descriptive, as it references the application ear file as missing the application.xml, which it was not.

                Anyway, moral of the story is, watch your file extension names.