0 Replies Latest reply on May 12, 2006 1:56 PM by Zoran Kokovic

    MyFaces Merge problem

    Zoran Kokovic Newbie

      Hello,

      I?m having problems using MyFaces1.1.1 & JSF1.1 RI in NetBeans 5.0 with JBoss 4.0.3SP1. First I deleted jsf-libs folder from deploy\jbossweb-tomcat55.sar and I used libraries imported in my project. Every time I deploy application, JBoss server, while deploying, logs merge of each component, and it needs about 45 seconds to do that! The biggest problem is that my backing bean doesn?t load each time. Often I have to deploy same application several times to get it work. I just don?t get it.

      After that, I tried to solve this problem by adding jsf-libs folder to deploy\jbossweb-tomcat55.sar, and removing MyFaces libraries from my project. I edited web.xml file by adding

      - <init-param>
      MyFacesAll tlds
      <param-name>tagLibJar1</param-name>
      <param-value>jsf-libs/myfaces-all.jar</param-value>
      </init-param>
      - <init-param>
      Tomahawk tlds
      <param-name>tagLibJar2</param-name>
      <param-value>jsf-libs/tomahawk.jar</param-value>
      </init-param>
      - <init-param>
      Sandbox tlds
      <param-name>tagLibJar3</param-name>
      <param-value>jsf-libs/sandbox.jar</param-value>
      </init-param>

      But it still does the same thing.

      When I completely remove MyFaces,and use only JSF RI, I don?t have any problems. Application needs about 3 sec to deploy and backing bean is loaded each time.
      I?m becoming despaired. I want to use MyFaces so I don?t have to manualy write some of it?s good solutions. SOS, help is needed.


      Respect
      Zoran
      UWP team, FOS , Belgrade