5 Replies Latest reply on Jun 1, 2006 12:12 PM by Scott Stark

    cant get the 404GA running from eclipse IDE

    Will Woodman Newbie

      Just starting out and have run into a problem

      run the install for jboss 404 ga.

      if i go to the bin dir and run by hand it starts fine. Kill server.

      go into eclipse with 1.6GA IDE

      I try and setup a server on the bottom line of the screen

      vm options are

      -Dprogram.name=run.bat -Djava.endorsed.dirs=C:/Program Files/jboss-4.0.4.GA/bin/../lib/endorsed -Xms128m -Xmx512m
      


      and working directory
      C:/Program Files/jboss-4.0.4.GA/bin
      


      when i try and start the server from within the IDE it fails and I get

      console error
      [list=]
      java.lang.NoClassDefFoundError: Files/jboss-4/0/4/GA/bin////lib/endorsed
      Exception in thread "main"


      and the server wont run.


      If i run the server by hand outside of eclipse and try - it claims (correctly ) that port 8080 is in use.

      what am i missing - this is most frustrating. EJB3 may be the way to go but i cant get past the first hurdle.


        • 1. Re: cant get the 404GA running from eclipse IDE
          Will Woodman Newbie

          Is there any one who can help with this - I cant get pass this stumbling block and use the blessed tool.

          all i can see is the default vm args when you look at the ecllipse server

          -Dprogram.name=run.bat -Djava.endorsed.dirs=D:/Program Files/jboss-4.0.4.GA/bin/../lib/endorsed -Xms128m -Xmx512m

          this looks like it has too many '..' before the lib. However if i remove this entrie section and save - it seems to ignore the next time you view the config.

          Any ideas any one.

          the server starts fine by hand from the 404GA/bin dir with run.bat. just not from the IDE.

          • 2. Re: cant get the 404GA running from eclipse IDE
            John Holland Newbie

            JBoss doesn't like it when your path has a space in it, so in this case the problem is that you've installed it in the "Program Files" directory. I moved mine to C:\jboss4.0.3.GA and it fixed the problem.

            • 3. Re: cant get the 404GA running from eclipse IDE
              Will Woodman Newbie

              aubrey_holland - you are a genius

              cant believe how frustrating that has been. It works Fine the IDE we have a go. Thankyou for all of that. Cant remember reading that anywhere, perhaps a warning on the IDE site would be appropriate.

              I cant be the first idiot to install it in the C:\program files location.

              Thanks again from a happy camper!

              • 4. Re: cant get the 404GA running from eclipse IDE
                Yannick BIET Newbie

                I ran into this issue yesterday and found the same fix as mentioned the posts above but I don't know if the problem comes from JBoss or Eclipse Integration, specially of Lomboz plusgin I use to start stop Jboss server...

                Anyway definitively, fix to the problem is to install JBoss to a simple path like C:\Jboss :)

                • 5. Re: cant get the 404GA running from eclipse IDE
                  Scott Stark Master

                  This is an eclipse integration problem. You can install into a path with spaces (such as C:\Program Files\jboss-4.0.4.GA) and run without problems:

                  [starksm@banshee9100 bin]$ pwd
                  /Program Files/jboss-4.0.4.GA/bin
                  [starksm@banshee9100 bin]$ run
                  =========================================================================
                  
                   JBoss Bootstrap Environment
                  
                   JBOSS_HOME: C:\Program Files\jboss-4.0.4.GA
                  
                   JAVA: /usr/java/jdk1.5.0_05/bin/java
                  
                   JAVA_OPTS: -server -Xms128m -Xmx512m -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000 -Dprogram.name=run.sh
                  
                   CLASSPATH: C:\Program Files\jboss-4.0.4.GA\bin\run.jar;C:\usr\java\jdk1.5.0_05\lib\tools.jar
                  
                  =========================================================================
                  
                  09:10:30,922 INFO [Server] Starting JBoss (MX MicroKernel)...
                  09:10:30,922 INFO [Server] Release ID: JBoss [Zion] 4.0.4.GA (build: CVSTag=JBo
                  ss_4_0_4_GA date=200605151000)
                  09:10:30,922 INFO [Server] Home Dir: C:\Program Files\jboss-4.0.4.GA
                  09:10:30,922 INFO [Server] Home URL: file:/C:/Program Files/jboss-4.0.4.GA/
                  09:10:30,938 INFO [Server] Patch URL: null
                  09:10:30,938 INFO [Server] Server Name: default
                  09:10:30,938 INFO [Server] Server Home Dir: C:\Program Files\jboss-4.0.4.GA\ser
                  ver\default
                  09:10:30,938 INFO [Server] Server Home URL: file:/C:/Program Files/jboss-4.0.4.
                  GA/server/default/
                  09:10:30,938 INFO [Server] Server Log Dir: C:\Program Files\jboss-4.0.4.GA\serv
                  er\default\log
                  09:10:30,938 INFO [Server] Server Temp Dir: C:\Program Files\jboss-4.0.4.GA\ser
                  ver\default\tmp
                  09:10:30,938 INFO [Server] Root Deployment Filename: jboss-service.xml
                  09:10:31,469 INFO [ServerInfo] Java version: 1.5.0_05,Sun Microsystems Inc.
                  09:10:31,469 INFO [ServerInfo] Java VM: Java HotSpot(TM) Server VM 1.5.0_05-b05
                  ,Sun Microsystems Inc.
                  09:10:31,469 INFO [ServerInfo] OS-System: Windows XP 5.1,x86
                  ...
                  09:10:57,875 INFO [ChannelSocket] JK: ajp13 listening on /0.0.0.0:8009
                  09:10:57,906 INFO [JkMain] Jk running ID=0 time=0/78 config=null
                  09:10:57,922 INFO [Server] JBoss (MX MicroKernel) [4.0.4.GA (build: CVSTag=JBos
                  s_4_0_4_GA date=200605151000)] Started in 26s:984ms