2 Replies Latest reply on Jul 17, 2006 9:12 AM by Mark Bobsin

    Failing to boot JBoss

    Mark Bobsin Newbie

      Please help as i am stumped.

      I have used JBoss quite a while ago a little and just re-installed the latest versions on a new computer (Windows XP).

      I have Sun Java JDK version 1.5.0 Update 7 and JBoss AS 4.0.4.GA.

      This is the error I am geting...

      Is the double slash '\\' in the JBOSS_HOME & CLASSPATH ok...this looks a little out of place?

      ===============================================================================
      .
      JBoss Bootstrap Environment
      .
      JBOSS_HOME: C:\Program Files\JBoss\jboss-4.0.4.GA\bin\\..
      .
      JAVA: C:\Java\jdk1.5.0_07\bin\java
      .
      JAVA_OPTS: -Dprogram.name=run.bat -Xms128m -Xmx512m -Dsun.rmi.dgc.client.gcIn
      terval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000
      .
      CLASSPATH: C:\Java\jdk1.5.0_07\lib\tools.jar;C:\Program Files\JBoss\jboss-4.0.
      4.GA\bin\\run.jar
      .
      ===============================================================================
      .
      Failed to boot JBoss:
      java.lang.ClassNotFoundException: org.jboss.system.server.ServerImpl
      at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
      at org.jboss.system.server.ServerLoader.createServer(ServerLoader.java:2
      85)
      at org.jboss.system.server.ServerLoader.load(ServerLoader.java:267)
      at org.jboss.Main.boot(Main.java:194)
      at org.jboss.Main$1.run(Main.java:464)
      at java.lang.Thread.run(Thread.java:595)
      Press any key to continue . . .