0 Replies Latest reply on Aug 10, 2006 3:04 PM by Shudong Lu

    How to force JBoss to read my own xmlrpc.jar?

    Shudong Lu Newbie

      We have an application(let's call it myapp) running fine on Tomcat(no JBoss). In myapp, we modified the source code of Apache xmlrpc and have our own xmlrpc.jar.

      We are trying to port myapp to JBoss with embedded Tomcat. Deployment failed with the exception:
      java.lang.NoSuchMethodError: org.apache.xmlrpc.XmlRpcClient.execute(Ljava/lang/String;Ljava/util/Vector;I)Ljava/lang/Object;
      This method is what we changed and thus is not in the standard Apache xmlrpc.jar. It is in our modified xmlrpc.jar. I could not make JBoss to read our modified xmlrpc.jar. I tried to put it under:
      ../server/default/deploy/myapp.war/WEB-INF/lib
      ../server/default/deploy
      ../server/default/lib
      ../lib
      ../lib/endorsed
      Then restarted JBoss each time. None worked -- the same exception every time. It seems to me JBoss is always reading the original Apache xmlrpc.jar from some where. Where is it? How can I force JBoss to read my modified xmlrpc.jar?

      I checked my $CLASSPATH which did not include xmlrpc.jar.

      JBoss AS 4.0.4
      java 1.5.0_06
      Solaris 10

      Thanks,

      Shudong