2 Replies Latest reply on Aug 15, 2006 10:50 AM by Peter Johnson

    JBoss documentation is driving me nuts

    Saurabh Garg Newbie

      I have tried this multiple times, so there has to be something wrong here. Basically, I have downloaded and compiled the source for Jboss AS 4.0.4GA. Now, I am trying to install JBoss Portal on top of it. I am still trying out RC1 due to some issues with forums I have been told in the later versions. Well, when I download the source, the entire "thirdparty" directory is missing, unlike in the documentation. Well, when I try "build datasource" I get an error that the target isn't defined. If I do a "build deploy" from the build directory, it downloads the thirdparty and other directories, but the "build datasource" from the core directory still doesn't work.

      Why is there such an ambiguous documentation? Is there a nice helpful HOWTO/tutorial book out there?

      Thanks for the help!

        • 1. Re: JBoss documentation is driving me nuts
          Saurabh Garg Newbie

          The specific error is:

          C:\Jboss\jboss-portal-2.4.0-CR1-src\core>build datasource
          build.bat: *ERROR* The target executable does not exist:
          build.bat:
          build.bat: C:\Jboss\jbp-2.4\tools\bin\build.bat
          build.bat:
          build.bat: Please make sure you have checked out the 'tools' module
          build.bat: and make sure it is up to date.

          • 2. Re: JBoss documentation is driving me nuts
            Peter Johnson Master

            I'm trying to recall what I did because I have 2.4CR1 source on my PC, and it looks like I built it. But I think what I did is download both the binary and the source. I did build the source by running build without any targets. But for the *-ds.xml file, I think I got that from the binary download.

            Found the datasource target. You have to be in the core directory to run "build datasource". Surprisingly enough, that is what the instructions in the reference guide say.