1 Reply Latest reply: Dec 6, 2006 11:56 AM by Steve Jagels RSS

    jndi deployment failure

    Steve Jagels Newbie

      I have a jndi file:

      <?xml version="1.0" encoding="UTF-8"?>

      <!-- Dev Datasource -->

      <local-tx-datasource>
      <jndi-name>providerqDbInfo</jndi-name>
      <connection-url>jdbc:JSQLConnect://myserver/database=mydatabase&sqlVersion=8</connection-url>
      <driver-class>com.ibm.as400.access.AS400JDBCDriver</driver-class>
      <user-name>abcdef</user-name>
      ghijklm

      <check-valid-connection-sql>Select 1</check-valid-connection-sql>


      <type-mapping>MS SQLSERVER2000</type-mapping>


      <min-pool-size>5</min-pool-size>
      <max-pool-size>100</max-pool-size>
      <blocking-timeout-millis>120000</blocking-timeout-millis>
      <idle-timeout-minutes>15</idle-timeout-minutes>

      <Pool.MaximumActiveConnections>100</Pool.MaximumActiveConnections>
      <Pool.MaximumIdleConnections>30</Pool.MaximumIdleConnections>
      <Pool.MaximumWait>60000</Pool.MaximumWait>

      <Pool.ValidationQuery>select 1</Pool.ValidationQuery>
      <Pool.LogAbandoned>false</Pool.LogAbandoned>
      <Pool.RemoveAbandoned>false</Pool.RemoveAbandoned>
      <Pool.RemoveAbandonedTimeout>50000</Pool.RemoveAbandonedTimeout>

      <Pool.MaximumCheckoutTime>120000</Pool.MaximumCheckoutTime>
      <Pool.TimeToWait>20000</Pool.TimeToWait>
      <Pool.PingQuery>select 1</Pool.PingQuery>
      <Pool.PingEnabled>true</Pool.PingEnabled>
      <Pool.PingConnectionsOlderThan>0</Pool.PingConnectionsOlderThan>
      <Pool.PingConnectionsNotUsedFor>0</Pool.PingConnectionsNotUsedFor>
      <Pool.QuietMode>true</Pool.QuietMode>
      </local-tx-datasource>





      When I start up jboss, jboss comes up, but it lists the following error in the console:

      org.jboss.deployment.DeploymentInfo@f6ddd783 { url=file:/C:/Java/JBoss 4.0.4/server/default/deploy/z-pq-DV-ds.xml }
      deployer: org.jboss.deployment.XSLSubDeployer@4d2b11
      status: null
      state: FAILED
      watch: file:/C:/Java/JBoss 4.0.4/server/default/deploy/z-pq-DV-ds.xml
      altDD: null
      lastDeployed: 1165420843219
      lastModified: 1165420843209
      mbeans:


      Then when I go to the application, the first sql hit produces this error:

      There was an error configuring JndiDataSourceDaoTransactionPool. Cause: javax.naming.NameNotFoundException: providerqDbInfo not bound

      What should I do?

      I should note that I set up another application with its jndi file set up in a very similar manner and that has had no problems.