0 Replies Latest reply on Jan 5, 2007 5:12 AM by Lukasz Strzeszynski

    Naming service problem

    Lukasz Strzeszynski Newbie

      Hi All

      I run jboss-4.0.5.GA, I am trying to integrate the Jboss with WebSphere MQ, using the Jboss Wiki page:
      http://wiki.jboss.org/wiki/Wiki.jsp?page=IntegrationWithWebSphereMQSeries

      When running the test:
      $ant wsmq-tests
      It tries to connect to the JBoss bootstrap port and throws exception:

      [java] javax.naming.CommunicationException: Could not obtain connection to any of these urls: localhost:1099 and discovery failed with error: javax.naming.CommunicationException: Receive timed out [Root exception is java.net.SocketTimeoutException: Receive timed out] [Root exception is javax.naming.CommunicationException: Failed to connect to server localhost:1099 [Root exception is javax.naming.ServiceUnavailableException: Failed to connect to server localhost:1099 [Root exception is java.net.ConnectException: Connection refused: connect]]]


      I run the default configuration in:
      c:\jboss-4.0.5.GA\server\default\deploy\naming.sar\META-INF\jboss-service.xml
      I have
      <mbean code="org.jboss.naming.NamingService" name="jboss:service=Naming"
      xmbean-dd="resource:xmdesc/NamingService-xmbean.xml">
      <attribute name="CallByValue">false</attribute>
      <attribute name="Port">1099</attribute>
      <attribute name="BindAddress">${jboss.bind.address}</attribute>


      unfortunately when I do a netstat -an I do NOT see the 1099 port.
      During the startup process of the server all resources binds properly,
      so I have no idea why it nothing is listening on this port.
      I am new in Jboss, thanks in advance for any help.

      Best Regards
      Lukasz