4 Replies Latest reply on Mar 31, 2007 10:35 AM by Ioannis Tsiokos

    error 202: handshake failed

    Ioannis Tsiokos Newbie


      Hi there,
      i hope somebody can help me with this...

      Afte i run jboss, i get:
      Listening for transport dt_socket at address: 8787

      When i try to load jmx in firefox from http://localhost:8787/jmx-console/
      i get the following error:

      transport error 202: handshake failed - received >GET /jmx-conso< - excepted >JDWP-Handshake< ["transport.c",L41]
      JDWP exit error JVMTI_ERROR_NONE(0): could not connect, timeout or fatal error

      Firefox returns an empty screen. If i try to load the jmx console inside IE, the error does not show up in the cmd and the browser can not find a page.

      I am lost :-(

      any help would be greatly appreciated :)

        • 1. Re: error 202: handshake failed
          Peter Johnson Master

          Sounds like you are started JBossAS with JVM debugging set and you are now attempting to connect to the debugging port. The HTTP port is 8080, so try http://localhost:8080/jmx-console

          • 2. Re: error 202: handshake failed
            Ioannis Tsiokos Newbie


            thank you peter for the help

            i started jboss as before and tried your suggestion.
            Unfortunately, http://localhost:8080/jmx-console does not work.

            i looked into the run.conf file and the
            #JAVA_OPTS="$JAVA_OPTS -Xdebug -Xrunjdwp:transport=dt_socket,address=8787,server=y,suspend=y"
            line is commented out, However, it is still used when i run jboss. I checked if the winodws JAVA_OPTS environmental variable was set to debug, but it was not. I am not sure why jboss is set to debug mode, especially since this is a fresh installation. Even then though, shouldn't it still work at port 8080?

            any other ideas?

            • 3. Re: error 202: handshake failed
              Peter Johnson Master

              The run.conf file is used for Linux only it is not used on Windows. But the same settings in run.bat are commented out also. I imagine that if I sat at your computer for a minute I could figure out exactly what is wrong and fix it. But since I cannot, I will give you step-by-step instructions to get the app server running, from scratch.

              1) Get a 1.5 JDK from http://java.sun.com/javase/downloads/index_jdk5.jsp.

              2) Install it. When it installs, do NOT place it into Program Files. Spaces in directory names cause various Java libraries fits, and unless you like chasing wierd problems, stick with plainer directory names. My JDK is installed at c:\apps\jdk1.5.0_11.

              3) Set the JAVA_HOME environment variable in the system properties. To do this, right click My Computer, go to Advanced tab, click the Environment variables button, and under System Variables click New. Set it to where you installed the JDK. On my system, I set it to c:\apps\jdk1.5.0_11

              4) Download the 4.0.5 version of the app server from http://labs.jboss.com/portal/jbossas/download. Click the Download link next to 4.0.5 (do not click Run Installer nor click Download Installer).

              5) The download is a zip file. Unzip it. I unzipped mine into c:\apps and got c:\apps\jboss-4.0.5.GA.

              6) Open a command prompt at c:\apps\jboss-4.0.5.GA\bin, and enter: run

              Wait until you see a message like:

              19:06:27,343 INFO [Server] JBoss (MX MicroKernel) [4.0.5.GA (build: CVSTag=Branch_4_0 date=200610162339)] Started in 50s:468ms

              Once you see that messages, you should be able to open a browser on the same system and enter http://localhost:8080/jmx-console.

              • 4. Re: error 202: handshake failed
                Ioannis Tsiokos Newbie


                thank u so much :)

                before, i was installing jboss by running java -jar jems-installer-1.2.0.GA.jar, which for some reason defaulted it to the debug mode

                everything works fine now!