3 Replies Latest reply on Oct 26, 2007 4:53 AM by Peter Holroyde

    Coldfusion WAR Deployment fun

    Peter Holroyde Newbie

      Hello all,

      I'm a software developer trying to deploy a website packaged in a war file using a fresh jboss install on a dev machine. The website is written in coldfusion and the war file was generated by coldfusion MX7.

      When i start the server it loads but throws a pile of erros upon encountering my war file.

      First error in server.log:
      --------------------------------------------------------------------------------------
      2007-10-24 16:09:39,359 ERROR [org.apache.catalina.startup.ContextConfig] Parse error in application web.xml file at jndi:/localhost/test_webstite/WEB-INF/web.xml
      java.lang.IllegalArgumentException: Invalid <url-pattern> *.cfml/* in servlet mapping
      at org.apache.tomcat.util.digester.Digester.createSAXException(Digester.java:2807)
      at org.apache.tomcat.util.digester.Digester.createSAXException(Digester.java:2833)
      at org.apache.tomcat.util.digester.Digester.endElement(Digester.java:1139)
      at org.apache.xerces.parsers.AbstractSAXParser.endElement(Unknown Source)
      ...
      ...
      --------------------------------------------------------------------------------------
      then further down i get this:

      --------------------------------------------------------------------------------------
      --- Incompletely deployed packages ---
      org.jboss.deployment.DeploymentInfo@c584878e { url=file:/C:/jboss-4.2.2.GA/server/default/deploy/test_webstite.war }
      deployer: MBeanProxyExt[jboss.web:service=WebServer]
      status: Deployment FAILED reason: URL file:/C:/jboss-4.2.2.GA/server/default/tmp/deploy/tmp41423test_webstite-exp.war/ deployment failed
      state: FAILED
      watch: file:/C:/jboss-4.2.2.GA/server/default/deploy/test_webstite.war
      altDD: null
      lastDeployed: 1193238578531
      lastModified: 1193238578484
      mbeans:

      --- MBeans waiting for other MBeans ---
      ObjectName: jboss.web.deployment:war=test_webstite.war,id=-981170290
      State: FAILED
      Reason: org.jboss.deployment.DeploymentException: URL file:/C:/jboss-4.2.2.GA/server/default/tmp/deploy/tmp41423test_webstite-exp.war/ deployment failed

      --- MBEANS THAT ARE THE ROOT CAUSE OF THE PROBLEM ---
      ObjectName: jboss.web.deployment:war=test_webstite.war,id=-981170290
      State: FAILED
      Reason: org.jboss.deployment.DeploymentException: URL file:/C:/jboss-4.2.2.GA/server/default/tmp/deploy/tmp41423test_webstite-exp.war/ deployment failed
      --------------------------------------------------------------------------------------

      any ideas how i could go about fixing this?

      does anybody have any experience running coldfusion sites in jboss? any help greatly appreciated!

      Pete

        • 1. Re: Coldfusion WAR Deployment fun
          Elias Ross Master

          Your web.xml is not spec-compliant, and apparently coldfusion supports a non-standard url-pattern. Change it to "*.cfml"

          • 2. Re: Coldfusion WAR Deployment fun
            Peter Holroyde Newbie

            Hi and thanks for the reply!

            i've changed the url pattern, and a few others which were the same. now i'm getting

            this:

            --------------------------------------------------------------------------------------
            2007-10-25 09:14:50,546 ERROR [STDERR] no such classpath element: ./WEB-INF/../../../classes
            2007-10-25 09:14:50,546 ERROR [STDERR] C:\jboss-4.2.2.GA\lib\updates: directory does not exist, hotfixes cannot be applied
            2007-10-25 09:14:51,609 ERROR [STDERR] javax.servlet.ServletException: The configuration file cound not be found at C:\jboss-4.2.2.GA\server\default\tmp\deploy\tmp29532siwtchgear-exp.war\WEB-INF\flex\flex-config.xml
            --------------------------------------------------------------------------------------

            and

            --------------------------------------------------------------------------------------
            2007-10-25 09:14:51,640 INFO [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/siwtchgear]] failed to load: flex.server.j2ee.cache.CacheFilter
            2007-10-25 09:14:51,640 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/siwtchgear]] Exception starting filter CFCacheFilter
            javax.servlet.ServletException: javax.servlet.ServletException: The configuration file cound not be found at C:\jboss-4.2.2.GA\server\default\tmp\deploy\tmp29532siwtchgear-exp.war\WEB-INF\flex\flex-config.xml
            at coldfusion.bootstrap.ClassloaderHelper.initFilterClass(ClassloaderHelper.java:132)
            at coldfusion.bootstrap.BootstrapFilter.init(BootstrapFilter.java:34)
            --------------------------------------------------------------------------------------

            thanks muchly for the help

            Pete

            • 3. Re: Coldfusion WAR Deployment fun
              Peter Holroyde Newbie

              *bump*

              still stuck! ^__^