6 Replies Latest reply on Feb 4, 2008 3:12 PM by Peter Johnson

    Jboos Wiki install - help

    Rotsen Zerolf Newbie

      I am running jboss-portal-2.6.3.GA on windows and I downloded and deployed the wiki.war.zip using the Manage Content in the CMS tag and
      I choose upload archive.

      After the wiki is loaded I can see it in the deploy directory the wiki.war folder but when I got to a page layout and choose cms in content type under content definition and I click on wiki.war it opens the folder up and then I do not know what to choose. At one point I chose the jsp forlder and then wiki.jsp but I got a page that was not rendering correct with errors.

      My questions is: What do I choose, to have the wiki available so that I can add it as a cms portlet in a page?

      I have done a lot of searches about this but I have not found anything so far.

      Thanks - Rotsen

        • 1. Re: Jboos Wiki install - help
          Peter Johnson Master

          Your mistake was in using CMS to upload the wiki.war file. The correct way to add the wiki to the portal is to copy the wiki.war file to the server/xxx/deploy directory.

          • 2. Re: Jboos Wiki install - help
            Rotsen Zerolf Newbie

            After I unzip the wiki.zip file and put the wiki.war file in my deploy folder
            I get errors in the tab where I added the wiki.

            Errors:
            HTTP Status 500 -

            type Exception report

            message

            description The server encountered an internal error () that prevented it from fulfilling this request.

            exception

            javax.servlet.ServletException: javax.resource.ResourceException: Transaction is not active: tx=TransactionImple < ac, BasicAction: a64057e:469:479f90ca:78c2 status: ActionStatus.ABORT_ONLY >
            org.jboss.portal.server.servlet.PortalServlet.service(PortalServlet.java:276)
            javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
            org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)

            root cause

            javax.resource.ResourceException: Transaction is not active: tx=TransactionImple < ac, BasicAction: a64057e:469:479f90ca:78c2 status: ActionStatus.ABORT_ONLY >
            org.jboss.resource.connectionmanager.TxConnectionManager.getManagedConnection(TxConnectionManager.java:304)
            org.jboss.resource.connectionmanager.BaseConnectionManager2.allocateConnection(BaseConnectionManager2.java:396)
            org.jboss.resource.connectionmanager.BaseConnectionManager2$ConnectionManagerProxy.allocateConnection(BaseConnectionManager2.java:842)
            org.jboss.resource.adapter.jdbc.WrapperDataSource.getConnection(WrapperDataSource.java:88)
            org.hibernate.connection.DatasourceConnectionProvider.getConnection(DatasourceConnectionProvider.java:69)
            more stuff............
            more stuff............
            org.jboss.portal.server.aspects.LockInterceptor.invoke(LockInterceptor.java:130)
            org.jboss.portal.common.invocation.Invocation.invokeNext(Invocation.java:115)
            org.jboss.portal.common.invocation.Invocation.invoke(Invocation.java:157)
            org.jboss.portal.server.servlet.PortalServlet.service(PortalServlet.java:250)
            javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
            org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)


            I put the first few lines a the last few lines. Does this mean anything to you guys? I am not a Java person.

            10Q - rotseN

            • 3. Re: Jboos Wiki install - help
              Rotsen Zerolf Newbie

              I hate to bother you guys again but when I drop the wiki.war file into my deployer folder it fails
              with the errors and warnings on my previous message.

              Am I missing a step? Should I edit a file?

              Any ideas?

              10Q - rotseN

              • 4. Re: Jboos Wiki install - help
                Peter Johnson Master

                I'm running the wiki on Portal 2.6.2. All I did was drop the wiki.war into the deploy folder. As far as I know, the wiki does not use the database (it stores the wiki contents on disk), so I do not think that the errors are necessarily wiki related.

                A few thoughts:

                1) I'm not sure if the wiki has been updated to run on 2.6.3 (I haven't tried it, and judging from earlier posts the wiki tends to be picky about which Portal version it runs with). Try running it on 2.6.2, if that works, you need to use that version.

                2) Did you start over from scratch with an empty database? Perhaps the wiki contents being in CMS is causing the issue. I would first bring up just the Portal (with a clean install and clean database), and after verifying that that is running, I would bring down the app server, copy the wiki.war to the deploy folder, and then start it again.

                • 5. Re: Jboos Wiki install - help
                  Rotsen Zerolf Newbie

                  Peter,

                  Following you last email, I went ahead and downloaded jboss-portal-2.6.2.GA and installing I them deployed the wiki.war
                  file and it automatically creates a TAB on my default page. When I clicked on the Wikiportlet tab I get the same errors.

                  You mentioned something (2) about databases. Maybe that is where I am going wrong. I have not done anything with databases.

                  I know that I did not have any problems in 2.63 until I deploy the wiki.war, I was able to deploy the IFrame without errors.

                  Am I supposed to set up a database before I can deploy the wiki?

                  10Q - rotseN

                  • 6. Re: Jboos Wiki install - help
                    Peter Johnson Master

                    I assume that you are using the JBoss Portal + JBossAS bundle. I base this on you statement that you never set up a database - the bundle comes with Hypersonic set up as the database.

                    I downloaded the 2.6.2 bundle, deployed wiki.war, and started the portal. Works fine. I then repeated this with the 2.6.3 bundle. Works fine.

                    The exception you posted is what appears in the browser window. This usually is not all that helpful. There should be a corresponding stack trace in the console window, could you post that?

                    What operating system are you using? Which version of the JDK?